Bug 596435 - nouveau "soft lockup" on boot
Summary: nouveau "soft lockup" on boot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 18:27 UTC by Neil Katin
Modified: 2010-05-26 20:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-26 20:13:26 UTC
Type: ---


Attachments (Terms of Use)
dmesg output (121.61 KB, text/plain)
2010-05-26 18:29 UTC, Neil Katin
no flags Details

Description Neil Katin 2010-05-26 18:27:40 UTC
Description of problem:

I upgraded to fedora13 today, my display no longer works.
It appears that the nouveau driver locks up in the kernel if
I boot without "nouveau.modeset=0" (which I used to have for
fedora12, kernel version 2.3.31)

The relevant section of the logs seem to be:

[drm] nouveau 0000:01:00.0: PFIFO_INTR 0x00000010 - Ch 1
BUG: soft lockup - CPU#0 stuck for 61s! [events/0:9]
Modules linked in: nouveau(+) ttm drm_kms_helper drm i2c_algo_bit video output i2c_core
CPU 0
Pid: 9, comm: events/0 Not tainted 2.6.33.4-95.fc13.x86_64 #1 0HX767/Vostro 1700
RIP: 0010:[<ffffffff8104bc09>]  [<ffffffff8104bc09>] release_console_sem+0x15e/0x1be
RSP: 0018:ffff88007dbcddc0  EFLAGS: 00000246
RAX: 0000000000000010 RBX: ffff88007dbcdde0 RCX: ffffffff81239248
RDX: 00000000ffffffff RSI: 000000000010a14d RDI: 0000000000000246
mBP: ffffffff8100a4ce R08: 0000000000000000 R09: ffff88007a2baeb0
R10: ffffffff81637c30 R11: ffff88007a2baeb0 R12: ffff88003740c210
R13: ffffffff81cd1bdd R14: 0100000200000002 R15: 0000000000000037
FS:  0000000000000000(0000) GS:ffff880001e00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 00007fd6387be000 CR3: 0000000001a3b000 CR4: 00000000000006f0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process events/0 (pid: 9, threadinfo ffff88007dbcc000, task ffff88007dbbdd40)
Stack:
 ffff88007f804000 ffff88007d10c000 0000000000000002 0000000000000e20
<0> ffff88007dbcde30 ffffffff812343be ffff88007dbcde30 ffffffff00000000
<0> ffff88007dbcde10 ffff880001e18240 ffff88007dbbdd40 ffff88007dbbdd40
Call Trace:
 [<ffffffff812343be>] ? fb_flashcursor+0xf8/0x107
 [<ffffffff81060d3d>] ? worker_thread+0x1a4/0x232
 [<ffffffff812342c6>] ? fb_flashcursor+0x0/0x107
 [<ffffffff81064817>] ? autoremove_wake_function+0x0/0x34
 [<ffffffff81060b99>] ? worker_thread+0x0/0x232
 [<ffffffff810643c7>] ? kthread+0x7a/0x82
 [<ffffffff8100a924>] ? kernel_thread_helper+0x4/0x10
 [<ffffffff8106434d>] ? kthread+0x0/0x82
 [<ffffffff8100a920>] ? kernel_thread_helper+0x0/0x10
Code: 0e 0b a0 00 48 8b 15 0f 0b a0 00 ff c8 45 39 ec 75 a6 41 89 fc 8b 15 4f 0b a0 00 44 89 e7 44 89 ee e8 e7 fa ff ff 4c 89 f7 57 9d <0f> 1f 44 00 00 e9 c9 fe ff ff 48 c7 c7 30 c7 a4 81 c7 05 44 bd
Call Trace:
 [<ffffffff812343be>] ? fb_flashcursor+0xf8/0x107
 [<ffffffff81060d3d>] ? worker_thread+0x1a4/0x232
 [<ffffffff812342c6>] ? fb_flashcursor+0x0/0x107
 [<ffffffff81064817>] ? autoremove_wake_function+0x0/0x34
 [<ffffffff81060b99>] ? worker_thread+0x0/0x232
 [<ffffffff810643c7>] ? kthread+0x7a/0x82
 [<ffffffff8100a924>] ? kernel_thread_helper+0x4/0x10
 [<ffffffff8106434d>] ? kthread+0x0/0x82
 [<ffffffff8100a920>] ? kernel_thread_helper+0x0/0x10


There are enough of these PFIFO_INTR messages that I don't have the
initial boot messages captured.

I'll attach full logs to the message.

Version-Release number of selected component (if applicable):

kernel: 2.6.33.4-95.fc13.x86_64

How reproducible:

Boot.  100% repeatable.

System will boot if nouveau.modeset=0 is set, but then X won't start up.

Additional info:

These drm kernel messages are output when booting with nouveau.modeset=0

May 26 09:53:17 neil-vostro kernel: input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A03:00/device:2d/LNXVIDEO:00/input/input8
May 26 09:53:17 neil-vostro kernel: ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)
May 26 09:53:17 neil-vostro kernel: [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
May 26 09:53:17 neil-vostro kernel: [drm] Initialized drm 1.1.0 20060810
May 26 09:53:17 neil-vostro kernel: pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
May 26 09:53:17 neil-vostro kernel: [drm] nouveau 0000:01:00.0: Detected an NV50 generation card (0x086700a2)
May 26 09:53:17 neil-vostro kernel: [drm] Initialized nouveau 0.0.16 20090420 for 0000:01:00.0 on minor 0

lspci output:

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M GS] (rev a1)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
03:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
03:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

Hardware: Dell Vostro 1700, bios A00

Comment 1 Neil Katin 2010-05-26 18:29:15 UTC
Created attachment 416969 [details]
dmesg output

Comment 2 Neil Katin 2010-05-26 20:13:26 UTC
deleting the 'vga=795' from my kernel boot line "fixed" the problem.  Mark this down to user confusion I guess.


Note You need to log in before you can comment on or make changes to this bug.