Bug 596524 - [abrt] crash in gmixer-1.3-12.fc12: display.py:523:send_and_recv:ConnectionClosedError: Display connection closed by server: Broken pipe
[abrt] crash in gmixer-1.3-12.fc12: display.py:523:send_and_recv:ConnectionCl...
Status: CLOSED DUPLICATE of bug 596442
Product: Fedora
Classification: Fedora
Component: gmixer (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:eddba60a
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 17:17 EDT by ringwald
Modified: 2010-05-26 17:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 17:37:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.65 KB, text/plain)
2010-05-26 17:17 EDT, ringwald
no flags Details

  None (edit)
Description ringwald 2010-05-26 17:17:24 EDT
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: /usr/bin/python -OO /usr/bin/gmixer -d
component: gmixer
executable: /usr/bin/gmixer
kernel: 2.6.32.11-99.fc12.i686
package: gmixer-1.3-12.fc12
reason: display.py:523:send_and_recv:ConnectionClosedError: Display connection closed by server: Broken pipe
release: Fedora release 12 (Constantine)

backtrace
-----
display.py:523:send_and_recv:ConnectionClosedError: Display connection closed by server: Broken pipe

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gtktrayicon.py", line 98, in reconnect_dock
    if self.update_manager_window(False):
  File "/usr/lib/python2.6/site-packages/gtktrayicon.py", line 167, in update_manager_window
    xdisplay = self.get_xdisplay()
  File "/usr/lib/python2.6/site-packages/gtktrayicon.py", line 161, in get_xdisplay
    xdisplay =  Xdisplay.Display(name)
  File "/usr/lib/python2.6/site-packages/Xlib/display.py", line 102, in __init__
    exts = self.list_extensions()
  File "/usr/lib/python2.6/site-packages/Xlib/display.py", line 676, in list_extensions
    r = request.ListExtensions(display = self.display)
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/rq.py", line 1428, in __init__
    self.reply()
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/rq.py", line 1440, in reply
    self._display.send_and_recv(request = self._serial)
  File "/usr/lib/python2.6/site-packages/Xlib/protocol/display.py", line 523, in send_and_recv
    raise self.socket_error
ConnectionClosedError: Display connection closed by server: Broken pipe

Local variables in innermost frame:
sending: 1
err: error(32, 'Broken pipe')
rs: [<socket._socketobject object at 0x9efabfc>]
self: <Xlib.display._BaseDisplay instance at 0x9e008cc>
req: <Xlib.protocol.request.ListExtensions serial = 2, data = None, error = None>
request: 2
flush_bytes: None
recieving: 1
ws: [<socket._socketobject object at 0x9efabfc>]
timeout: None
flush: None
wait: 1
recv: None
event: None
es: []
writeset: [<socket._socketobject object at 0x9efabfc>]
Comment 1 ringwald 2010-05-26 17:17:25 EDT
Created attachment 417033 [details]
File: backtrace
Comment 2 leigh scott 2010-05-26 17:37:54 EDT

*** This bug has been marked as a duplicate of bug 596442 ***

Note You need to log in before you can comment on or make changes to this bug.