Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596554 - Incorrect x86 CPU family/model check
Incorrect x86 CPU family/model check
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 19:19 EDT by H.J. Lu
Modified: 2016-11-24 10:41 EST (History)
3 users (show)

See Also:
Fixed In Version: glibc-2.11.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 18:29:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch (928 bytes, patch)
2010-05-26 19:20 EDT, H.J. Lu
no flags Details | Diff

  None (edit)
Description H.J. Lu 2010-05-26 19:19:53 EDT
This commit:

http://sourceware.org/git/?p=glibc.git;a=commit;h=22f4f44b6727887957aa1d4039eba290b064da63

breaks x86 CPU family/model check since we now check
__cpu_features.family and __cpu_features.model before
setting them.  I am enclosing a patch.
Comment 1 H.J. Lu 2010-05-26 19:20:26 EDT
Created attachment 417062 [details]
A patch
Comment 2 Fedora Update System 2010-06-02 04:36:19 EDT
glibc-2.12-2 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/glibc-2.12-2
Comment 3 Fedora Update System 2010-06-02 14:13:22 EDT
glibc-2.12-2 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/glibc-2.12-2
Comment 4 Fedora Update System 2010-06-07 18:29:06 EDT
glibc-2.12-2 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-10-21 08:11:30 EDT
glibc-2.11.2-2 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/glibc-2.11.2-2
Comment 6 Fedora Update System 2010-10-30 19:46:56 EDT
glibc-2.11.2-3 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.