Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 596580 - Migration from /usr/lib/news/bin to /usr/libexec/news is not complete
Migration from /usr/lib/news/bin to /usr/libexec/news is not complete
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
: 630484 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 22:55 EDT by David L. Crow
Modified: 2014-02-02 17:14 EST (History)
5 users (show)

See Also:
Fixed In Version: inn-2.5.1-5.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-26 00:38:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L. Crow 2010-05-26 22:55:34 EDT
Description of problem:
It appears that the inn's pathbin was changed from /usr/lib/news/bin to /usr/libexec/news in Fedora 13.  Unfortunately, many of the scripts and commands did not complete this transition.

Because of this, innd cannot start and the cron jobs fail.

I had to modify the following files after upgrade from Fedora 12 to Fedora 13:
/etc/cron.daily/inn-cron-expire
/etc/cron.hourly/inn-cron-nntpsend
/etc/cron.hourly/inn-cron-rnews
/etc/rc.d/init.d/innd
/usr/share/perl5/INN/Config.pm

Version-Release number of selected component (if applicable): inn-2.5.1-3.fc13.i686


How reproducible: very


Steps to Reproduce:
1. Inspect the files listed above for the /usr/lib/news/bin path
  
Actual results:
The path is found.

Expected results:
The path should not be found, but /usr/libexec/news should be found instead.

Additional info:

Not sure if I should open another bug for this, but the permissions for /usr/share/doc/inn-2.5.1/ and /usr/share/doc/inn-2.5.1/samples/ are 040644 which is not so good for a directory.
Comment 1 Nikola Pajkovsky 2010-06-02 10:20:42 EDT
Thank you for your report. Here is a build with fixes. Could you please test it and let me know? If it will be every thing fine I will commit in into cvs and submit update.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2225158
Comment 2 H. Peter Anvin 2010-06-09 01:43:25 EDT
With the koji build I still get:

/usr/libexec/news/rc.news: line 161: /usr/lib/news/bin/innd: No such file or directory

... which of course should be /usr/libexec/news/innd.

/usr/libexec/news/innconfval outputs:

PATHBIN='/usr/lib/news/bin'; export PATHBIN;
Comment 3 Nikola Pajkovsky 2010-06-09 04:20:54 EDT
[npajkovs@redhat.com ~]$ /usr/libexec/news/innconfval -s | grep PATHBIN
PATHBIN='/usr/libexec/news'; export PATHBIN

You've only updated package, right? Could you please try remove all packages and install new one from koji? I have a bad feeling that update does not work well.
Comment 4 H. Peter Anvin 2010-06-10 00:46:20 EDT
It looks like the issue is configuration variables in /etc/news/inn.conf.  This is a highly complex configuration file which is likely to have been customized by the administrator.  As you can see below, there are options which I really need from my existing inn.conf, as well as those that need to be updated to deal with this change:

E.g. (-) is inn.conf (+) in inn.conf.rpmnew:

-organization:           "Zytor Communications"
+organization:           "A poorly-installed InterNetNews site"

-pathhost:               news.zytor.com
-pathnews:               /usr/lib/news
+#pathhost:               localhost
+pathnews:               /usr

-mailcmd:                /usr/lib/news/bin/innmail
+mailcmd:                /usr/libexec/news/innmail

-pathbin:                /usr/lib/news/bin
-pathcontrol:            /usr/lib/news/bin/control
+pathbin:                /usr/libexec/news
+pathcontrol:            /usr/libexec/news/control

-pathfilter:             /usr/lib/news/bin/filter
-pathhttp:               /var/log/news
+pathfilter:             /usr/libexec/news/filter
+pathhttp:               /var/lib/news/http

The newsfeeds file needs similar changes.
Comment 5 Nikola Pajkovsky 2010-06-10 04:22:06 EDT
So it seems I've fixed issue, but your configuration reminds from 2.5.1-3. I will push a new updates.
Comment 6 David L. Crow 2010-06-10 10:35:10 EDT
Sorry for the delay in testing the new packages, but I finally installed them this morning and it appears that all the issues are resolved.
Comment 7 Fedora Update System 2010-07-02 08:17:47 EDT
inn-2.5.1-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/inn-2.5.1-4.fc13
Comment 8 Fedora Update System 2010-09-07 07:12:46 EDT
inn-2.5.1-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/inn-2.5.1-5.fc13
Comment 9 Fedora Update System 2010-09-07 22:22:56 EDT
inn-2.5.1-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update inn'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/inn-2.5.1-5.fc13
Comment 10 Nikola Pajkovsky 2010-09-13 05:39:53 EDT
*** Bug 630484 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2010-09-26 00:37:53 EDT
inn-2.5.1-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.