Bug 596585 - ValueError: Trying to pick boot devices but do not have a sane root partition
ValueError: Trying to pick boot devices but do not have a sane root partition
Status: CLOSED DUPLICATE of bug 592860
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 23:15 EDT by John Reiser
Modified: 2010-06-02 17:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 17:17:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda debug traceback (832.60 KB, text/xml)
2010-05-26 23:15 EDT, John Reiser
no flags Details
/tmp/storage.log (488.51 KB, text/plain)
2010-05-26 23:15 EDT, John Reiser
no flags Details
/tmp/program.log (187.00 KB, text/plain)
2010-05-26 23:16 EDT, John Reiser
no flags Details
/tmp/anaconda.log (19.35 KB, text/plain)
2010-05-26 23:16 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2010-05-26 23:15:08 EDT
Created attachment 417102 [details]
anaconda debug traceback

Description of problem: Installer dies upon clicking Next in Hostname dialog.


Version-Release number of selected component (if applicable):
anaconda-14.5

How reproducible: every time


Steps to Reproduce:
1. compose DVD of Fedora 14 rawhide using pungi; burn to DVD+RW
2. boot DVD for fresh install
3. basic disks, custom configuration, choose only one of 4 SATA drives (/dev/sdc)
4. enter hostname, click Next.
  
Actual results: installer error with traceback


Expected results: partitioning dialog


Additional info:
Comment 1 John Reiser 2010-05-26 23:15:53 EDT
Created attachment 417103 [details]
/tmp/storage.log
Comment 2 John Reiser 2010-05-26 23:16:22 EDT
Created attachment 417104 [details]
/tmp/program.log
Comment 3 John Reiser 2010-05-26 23:16:55 EDT
Created attachment 417105 [details]
/tmp/anaconda.log
Comment 4 John Reiser 2010-05-27 19:59:43 EDT
There are 4 SATA drives.  sda and sdb have DOS disk labels, sdc and sdd have GPT disk labels.  The selected partition is on sdc which has a GPT label.

GRUB boots any partition on any disk (25 other root partititions are scattered among the drives).  Later on I'm going to choose "Do not install boot loader" anyway, because my booting scheme cannot be described in a way that anconda understands.
Comment 5 Brian Lane 2010-06-02 17:17:42 EDT

*** This bug has been marked as a duplicate of bug 592860 ***

Note You need to log in before you can comment on or make changes to this bug.