Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596686 - service ejabberd stop doesn't kill epmd which prevents new start of ejabberd
service ejabberd stop doesn't kill epmd which prevents new start of ejabberd
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ejabberd (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 06:09 EDT by Matěj Cepl
Modified: 2018-04-11 08:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: ejabberd-2.1.4-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 16:00:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2010-05-27 06:09:42 EDT
Description of problem:
[root@luther ~]# service ejabberd stop
[root@luther ~]# pgrep -f -l erl
19870 /usr/lib/erlang/erts-5.6.5/bin/epmd -daemon
[root@luther ~]# 

Version-Release number of selected component (if applicable):
ejabberd-2.1.2-4.el5

How reproducible:
100%
Comment 1 Peter Lemenkov 2010-06-12 10:19:54 EDT
Could you, please, try with latest ejabberd:

https://admin.fedoraproject.org/updates/ejabberd-2.1.4-1.el5

In fact, ejabberd shouldn't kill epmd (because there may be other erlang applications running, which are using epmd), but it should cleanly unregister itself.
Comment 2 Matěj Cepl 2010-06-12 11:09:43 EDT
(In reply to comment #1)
> In fact, ejabberd shouldn't kill epmd (because there may be other erlang
> applications running, which are using epmd), but it should cleanly unregister
> itself.

Sure, I don't anything against poor epmd, except that it prevents (prevented) my ejabberd from running.
Comment 3 Matěj Cepl 2010-06-12 11:29:35 EDT
Looks good:

[root@luther ~]# service ejabberd restart
Shutting down ejabberd:                                    [  OK  ]
Starting ejabberd:                                         [  OK  ]
[root@luther ~]# service ejabberd status
The node ejabberd@luther is started with status: started
ejabberd 2.1.4 is running in that node
[root@luther ~]# 

Thank you!
Comment 4 Fedora Update System 2010-06-12 11:35:41 EDT
ejabberd-2.1.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ejabberd-2.1.4-1.fc13
Comment 5 Fedora Update System 2010-06-12 11:35:48 EDT
ejabberd-2.1.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ejabberd-2.1.4-1.fc12
Comment 6 Fedora Update System 2010-06-12 11:36:01 EDT
ejabberd-2.1.4-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/ejabberd-2.1.4-1.el5
Comment 7 Fedora Update System 2010-06-14 17:53:33 EDT
ejabberd-2.1.4-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ejabberd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ejabberd-2.1.4-1.el5
Comment 8 Fedora Update System 2010-07-14 18:59:47 EDT
ejabberd-2.1.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-07-14 19:05:19 EDT
ejabberd-2.1.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-07-21 16:00:11 EDT
ejabberd-2.1.4-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.