Bug 596713 - Job view does not load task results anymore with Konqueror
Summary: Job view does not load task results anymore with Konqueror
Status: CLOSED UPSTREAM
Alias: None
Product: Beaker
Classification: Community
Component: web UI   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
Assignee: Raymond Mancy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 11:12 UTC by Luigi Toscano
Modified: 2014-12-08 01:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 07:45:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luigi Toscano 2010-05-27 11:12:30 UTC
Description of problem:
The new ajax-based job view does not load anymore the list of tasks with Konqueror (4.4.2, F12). The buttons toggles between "Show Failed Results" and "Show All Results" (or "Hide Results"/"Show Failed Results") but nothing happens.

Version-Release number of selected component (if applicable):
beaker 0.5.40

Comment 1 Raymond Mancy 2010-05-27 21:20:29 UTC
I'll try updating the jquery version, see if that fixes it.

Comment 2 Frantisek Reznicek 2010-06-21 11:23:04 UTC
I'm having the same issue with konqueror 3.5-10 and it is very frustrating to always switch to Firefox just because of Beaker Web-UI.

Would it be possible to add Beaker personal option:
"Automatically show all task logs" which would show all jobs logs without clicking on "Show all results" button. Because in 99% user will click that button anyway!

I believe this is the best solution for wide range of people who use a bit older browsers.

May I ask you for considering this idea, please?

Comment 3 Jeff Needle 2010-06-21 11:26:52 UTC
I have to agree with Frantisek.  I was using Opera 10.0 and this was broken.  I also had an older firefox (1.5) which also didn't work.  I don't really see the value in making the logs completely inaccessible to "unsupported" browsers.  I would much rather we erred on the side of making too much information available to them, so Frantisek's suggestion above makes a lot of sense.

Comment 4 Raymond Mancy 2010-06-22 12:29:54 UTC
I'm upgrading jQuery in another ticket, and it seems to fix this problem in most browsers.  I'll close this ticket once the other bz has been resolved

Comment 5 Raymond Mancy 2010-06-23 07:45:42 UTC
jquery was updated in bz596410


Note You need to log in before you can comment on or make changes to this bug.