Bug 596846 - F12 nvr > F13 nvr
Summary: F12 nvr > F13 nvr
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: groff   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Vcelak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-27 16:01 UTC by Jonathan Underwood
Modified: 2013-03-04 01:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 16:18:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Underwood 2010-05-27 16:01:44 UTC
Description of problem:
Using preupgrade on a fully updated version of F-12 to F-13 and then running
package-cleanup --orphans lists groff as being orphaned. The reason is
that the F12 version has a greater nvr than the F13 version - see below. Please
push updated packages for F13.


# yum downgrade groff
Loaded plugins: presto, refresh-packagekit
Setting up Downgrade Process
Resolving Dependencies
--> Running transaction check
---> Package groff.x86_64 0:1.18.1.4-20.fc13 set to be updated
---> Package groff.x86_64 0:1.18.1.4-21.fc12 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package        Arch            Version                   Repository       Size
================================================================================
Downgrading:
 groff          x86_64          1.18.1.4-20.fc13          fedora          1.5 M

Transaction Summary
================================================================================
Remove        0 Package(s)
Reinstall     0 Package(s)
Downgrade     1 Package(s)

Total download size: 1.5 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 1.5 M
groff-1.18.1.4-20.fc13.x86_64.rpm                        | 1.5 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : groff-1.18.1.4-20.fc13.x86_64                            1/2 
  Cleanup        : groff-1.18.1.4-21.fc12.x86_64                            2/2 

Removed:
  groff.x86_64 0:1.18.1.4-21.fc12                                               

Installed:
  groff.x86_64 0:1.18.1.4-20.fc13                                               

Complete!

Comment 1 Jan Vcelak 2010-05-27 16:18:42 UTC
Hi Jonathan.

Thank you for your report. I have fixed it and submitted to stable updates a few hours ago.

https://admin.fedoraproject.org/updates/groff-1.18.1.4-21.fc13


Note You need to log in before you can comment on or make changes to this bug.