Bug 596850 - F-13 nvr < F-12 nvr
F-13 nvr < F-12 nvr
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Pechanec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 12:08 EDT by Jonathan Underwood
Modified: 2010-08-19 16:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 16:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2010-05-27 12:08:59 EDT
Description of problem:
Using preupgrade on a fully updated version of F-12 to F-13 and then running
package-cleanup --orphans lists  java-1.6.0-openjdk and java-1.6.0-openjdk-plugin as being orphaned. The reason is that the F12 version has a greater nvr than the F13 version - see below. Please push updated packages for F13.

# yum downgrade java-1.6.0-openjdk java-1.6.0-openjdk-plugin
Loaded plugins: presto, refresh-packagekit
Setting up Downgrade Process
Resolving Dependencies
--> Running transaction check
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-37.b17.fc13 set to be updated
---> Package java-1.6.0-openjdk.x86_64 1:1.6.0.0-38.b18.fc12 set to be erased
---> Package java-1.6.0-openjdk-plugin.x86_64 1:1.6.0.0-37.b17.fc13 set to be updated
---> Package java-1.6.0-openjdk-plugin.x86_64 1:1.6.0.0-38.b18.fc12 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch     Version                    Repository
                                                                           Size
================================================================================
Downgrading:
 java-1.6.0-openjdk          x86_64   1:1.6.0.0-37.b17.fc13      fedora    25 M
 java-1.6.0-openjdk-plugin   x86_64   1:1.6.0.0-37.b17.fc13      fedora   101 k

Transaction Summary
================================================================================
Remove        0 Package(s)
Reinstall     0 Package(s)
Downgrade     2 Package(s)

Total download size: 25 M
Is this ok [y/N]: 




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andre Robatino 2010-05-27 14:26:38 EDT
No, DON'T push this for F13.  The higher-numbered versions in F11 and F12 are broken (100% CPU for any java applets).

https://bugzilla.redhat.com/show_bug.cgi?id=592553
Comment 2 Andre Robatino 2010-05-27 14:30:27 EDT
I should have said, don't push the currently broken F11/F12 version - of course they should be fixed, then pushed.
Comment 3 Jonathan Underwood 2010-05-27 14:32:37 EDT
That's not what I was asking.

The point is the nvr in F13 needs ALWAYS to be equal or greater than that in F12 (and F11). No exceptions.
Comment 4 Andre Robatino 2010-05-27 14:49:10 EDT
> The point is the nvr in F13 needs ALWAYS to be equal or greater than that in
> F12 (and F11). No exceptions.

True, and the nvr in Rawhide should always be >= F13.  Unfortunately, the maintainer for some reason pushed to F11 and F12 before pushing to either pre-release F13 or Rawhide.
Comment 5 Jonathan Underwood 2010-05-27 15:00:18 EDT
Would doing this:

Push new builds of the b17 version to F11, F12, F13, bumping the epoch and ensuring that nvr(F11) <= nvr(F12) <= nvr(F13).

break anything? If not, that's probably the way to go until the b18 version is fixed properly.
Comment 6 Andre Robatino 2010-05-27 16:20:36 EDT
I guess it depends on how long it takes to fix - if it's quick, the fixed version could be pushed to F13 and Rawhide first without bumping the epoch.  There hasn't been any word from the maintainer yet so it's hard to say.

FYI, there's work on a new AutoQA test to prevent this sort of thing from happening again:

https://fedorahosted.org/autoqa/ticket/123
Comment 7 Fedora Update System 2010-06-10 08:47:13 EDT
java-1.6.0-openjdk-1.6.0.0-39.b18.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/java-1.6.0-openjdk-1.6.0.0-39.b18.fc13
Comment 8 Fedora Update System 2010-06-10 15:19:06 EDT
java-1.6.0-openjdk-1.6.0.0-39.b18.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Andre Robatino 2010-06-11 06:54:42 EDT
This can be closed as CURRENTRELEASE now.  (Too bad nothing got fixed.)  Since the maintainer doesn't seem to be aware of these bug's existence (or negative karma), you'll have to do it.

Note You need to log in before you can comment on or make changes to this bug.