Bug 5969 - Kickstart BOOTP load of ks.cfg broken in 6.1
Kickstart BOOTP load of ks.cfg broken in 6.1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-14 20:43 EDT by Fred Feirtag
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 14:36:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Feirtag 1999-10-14 20:43:13 EDT
Getting the ks.cfg file from a server with
:bf=/blah/bootp, then /blah/bootp/IPADDR-kickstart
which worked with no problems in 6.0 now fails.

From the <alt>F4 screen, it looks like it got the basic
bootp info fine, but never uses it to nfs mount and copy
the file to /tmp/ks.cfg.

It's a though -DINCLUDE_NETWORK wasn't done when compiling
loader for the bootnet image, if I'm even looking at the
right source code (.../misc/src/anaconda/loader/loader.c)?
It's substantially different than 6.0, and lives in a
different directory on the distribution.

Also the line with "umount("/tmp/nfs");" should probably be
"umount("/tmp/nfskd");"

switching from "ks" to "ks=floppy" and puting the ks.cfg
file on the floppy failed, though at least it was read.

Then right on the <alt>F1 screen I get:

Exception Occured
Traceback (innermost last):
File "/usr/bin/anaconda", line 224, in ?
extramodules = extraModules) File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/todo.py",
line 454, in __init__
self_setClass (inst Class) File
"../../../RedHat/instimage/usr/lib/python1.5/site-packages/todo.py",
line 1218, in setClass

I don't know how badly kickstart is broken, but it's one
of my favorite features of RedHat, so I'd love to see it
fixed.

Thanks,

Fred Feirtag
fdfeirt@sandia.gov
Comment 1 Jay Turner 1999-10-18 14:49:59 EDT
Not really sure that I know what you are getting at here.  We tested
retrieving the ks.cfg file from the bootp server here in the lab and
it works without fail.  Are you specifying the filename and
next-server parameters in your dhcpd.conf file?
Comment 2 Jay Turner 1999-10-21 14:42:59 EDT
This issue has been forwarded to a developer for further action.

------- Additional Comments From   10/28/99 10:48 -------
I have the same problem:

>Getting the ks.cfg file from a server with
>:bf=/blah/bootp, then /blah/bootp/IPADDR-kickstart
>which worked with no problems in 6.0 now fails.

Even using the old 6.0 bootfloppy on the same machine with
the same config gets all the information from the
kickstart file, mounts the nfs-installation directory
from another machine specified in the <IP>-kickstart
and only fails at the execution of the second stage
loader (probably because the directory structure of
6.1 is different from 6.0).

>From the <alt>F4 screen, it looks like it got the basic
>bootp info fine, but never uses it to nfs mount and copy
>the file to /tmp/ks.cfg.

It gets IP, Netmask, DNS-servers right, but doesn't use
the documented defaults (server same as BOOTP server, file
location /kickstart/<IP>-kickstart) to get the config which
works with 6.0. I could not find the right parameter to set
the server location in the BOOTP-Config /etc/bootptab
on the server (solaris 2.6).

On the <alt>F4-screen, it says
<15> .... bootServer 0.0.0.0
the last line is
<4>neighbour table overflow

<alt>F3 says No bootserver found.


Sven Lotze (lotze@cs.rwth-aachen.de)

------- Additional Comments From   11/10/99 12:00 -------
We too suffer from the same problem: KickStart failed to get the
config file using our bootpd server (which works fine for RH 6.0)
and the error is "no boot server was found"
Comment 3 lionel.cons 1999-11-17 07:48:59 EST
I've looked at the latest RawHide (19991111) and simply changing one line
in loader.c fixes the problem!!! I include the patch below.

Could this be fixed in your source tree so that we get updated diskette
images working with BOOTP?

FYI, we have 200+ machines that we would like to reinstall soon with 6.1...

--- loader.c.orig       Wed Nov 17 13:52:45 1999
+++ loader.c    Wed Nov 17 13:53:00 1999
@@ -1457,7 +1457,7 @@

     writeNetInfo("/tmp/netinfo", &netDev);

-    if (!(netDev.dev.set & PUMP_INTFINFO_HAS_BOOTSERVER)) {
+    if (!(netDev.dev.set & PUMP_INTFINFO_HAS_NEXTSERVER)) {
        logMessage("no bootserver was found");
        return 1;
     }
Comment 4 Justin Hahn 1999-11-18 12:59:59 EST
I should note that I'm seeing this as well. I'm using SunOS 5.6 as a bootserver
using bootp. I'm not using DHCP at all. This is essentially a show-stopper for
me. Recompiling loader-network from the sources on the 6.1 CD and commenting out
the following block in loader.c

if (!(netDev.dev.set & PUMP_INTFINFO_HAS_BOOTSERVER)) {
	logMessage("no bootserver was found");
        return 1;
}

appears to almost work, except it doesn't figure out where to go for the server.
Is there any hope of getting this work SOON?
Comment 5 Erik Troan 2000-02-23 14:36:59 EST
This should all be fixed in piglet.

Note You need to log in before you can comment on or make changes to this bug.