Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596912 - RFE: option to automatically extend loan/reservation of machine after RHTS test failure
RFE: option to automatically extend loan/reservation of machine after RHTS te...
Status: CLOSED DUPLICATE of bug 623933
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.5
All Linux
low Severity urgent (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 14:41 EDT by Frank Ch. Eigler
Modified: 2014-08-12 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 21:32:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2010-05-27 14:41:42 EDT
If an RHTS test case fails on an uncommon architecture (ppc, s390, ...), 
or very intermittently, it would be mighty convenient if the machine
could preserve its post-test state, and stay reserved awhile - say 12 hours. 
That way, an engineer has a fighting chance to reproduce the problem in situ, 
rather than hoping to reserve something similar, and hand-run the tests something
similarly.

I suspect the time saved by this may well make up for the reduced
utilization of the machines, but if one disagrees, this behavior
could be an option selected by rhts scripts.
Comment 1 Dan Callaghan 2012-09-27 21:32:14 EDT
You can now pass RESERVE_IF_FAIL=1 as a param to /distribution/reservesys and it will behave this way.

*** This bug has been marked as a duplicate of bug 623933 ***

Note You need to log in before you can comment on or make changes to this bug.