Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596930 - speaker automatic muting not working / snd-hda-intel / ALC269 / ThinkPad SL510
speaker automatic muting not working / snd-hda-intel / ALC269 / ThinkPad SL510
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 15:08 EDT by Mikko Huhtala
Modified: 2011-06-27 12:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 12:49:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikko Huhtala 2010-05-27 15:08:34 EDT
Description of problem:

Sound plays from laptop speakers even when headphones are plugged in.


Version-Release number of selected component (if applicable):

kernel-2.6.33.4-95.fc13.i686
alsa-lib-1.0.23-1.fc13.i686

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
Codec: Realtek ALC269


Expected results:

Automatic muting of the speakers when headphones are plugged in.


Additional info:

I tried passing each of the following to the kernel module with

options snd-hda-intel model=

   basic         Basic preset
   quanta        Quanta FL1
   eeepc-p703    ASUS Eeepc P703 P900A
   eeepc-p901    ASUS Eeepc P901 S101
   fujitsu       FSC Amilo
   lifebook      Fujitsu Lifebook S6420
   auto          auto-config reading BIOS (default)

None of them work on ThinkPad SL510. The 'lifebook' option will make the automute work correctly, but it kills the microphone entirely.
Comment 1 Chris Venker 2010-06-21 09:22:08 EDT
I have the same result, but unless Mikko, the option "lifebook" kills my overall sound (it had to be put in /etc/modprobe.d/dist-alsa.conf, or?)

As I read on some Gentoo-thread I tried a 2.6.34 kernel (2.6.34-43.fc13.x86_64, recompiled from source of 2.6.34-43.fc14.x86_64 obtained via koji) but it didn't help.

Kernel: kernel-2.6.33.5-124.fc13.x86_64
Alsalib: alsa-lib-1.0.23-1.fc13.x86_64

Over at Launchpad they have the same bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/580006

Maybe that info can help?
Comment 2 Mikko Huhtala 2010-06-28 02:47:42 EDT
Thanks for the link to the Launchpad bug. I read there about an easy workaround: the dedicated mute button to the left side of the ThinkPad's keyboard mutes the speakers but not the headphone line. I hadn't had the presence of mind to try this myself, and I installed Fedora on the machine on behalf of someone else, so I don't have the machine handy. A quick phone call confirmed that the mute button works perfectly in this case. The bug is still there on an up-to-date F13.
Comment 3 Michal Pomorski 2010-07-03 17:39:45 EDT
On my eeepc-901 the speakers dont get muted by the headphones either. It used to work in f11 and f12.
I added the line 'options snd-hda-intel model=eeepc-p901' to dist-alsa.conf with no effect.

alsactl init 0
Unknown hardware: "HDA-Intel" "Realtek ALC269" "HDA:10ec0269,1043831a,00100004" "0x1043" "0x831a"
Hardware is initialized using a guess method

lspci
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
Comment 4 Michal Pomorski 2010-07-03 19:03:08 EDT
my alsa-info:

http://www.alsa-project.org/db/?f=943cd26b44609c62ba1ec43b5b572d70f8ec26ad
Comment 5 Michal Pomorski 2010-07-03 19:22:41 EDT
In my case setting the 'options' to 'model=auto' fixed the issue. You think this is a separate bug or eeepc-901?
Comment 6 Bug Zapper 2011-06-02 09:12:36 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2011-06-27 12:49:53 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.