Bug 596980 - [abrt] crash after exit from _IceDefaultIOErrorHandler (on opening a .doc from firefox via mozplugger)
[abrt] crash after exit from _IceDefaultIOErrorHandler (on opening a .doc fro...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:820c1ef8fa33212aa2c02ab5000...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 16:51 EDT by Raffael Luthiger
Modified: 2010-06-08 09:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 09:14:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (39.14 KB, text/plain)
2010-05-27 16:51 EDT, Raffael Luthiger
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 111972 None None None Never

  None (edit)
Description Raffael Luthiger 2010-05-27 16:51:31 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/soffice.bin -quickstart -nologo -nodefault
component: openoffice.org
crash_function: com::sun::star::uno::cpp_queryInterface
executable: /usr/lib/openoffice.org3/program/soffice.bin
global_uuid: 820c1ef8fa33212aa2c02ab50003a8a24870508e
kernel: 2.6.32.12-115.fc12.i686
package: openoffice.org-brand-1:3.1.1-19.28.fc12
rating: 4
reason: Process /usr/lib/openoffice.org3/program/soffice.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Open a normal OpenOffice Writer document
2. Start Firefox
3. Click within Firefox on a link to a DOC file and the document gets loaded with the plugin and the plugin crashes along with the other OpenOffice Writer window.
Comment 1 Raffael Luthiger 2010-05-27 16:51:33 EDT
Created attachment 417380 [details]
File: backtrace
Comment 2 David Tardon 2010-05-28 01:37:27 EDT
Does not crash here. Can you reproduce it with a specific link to a doc file? If yes, could you try to save the doc and open it normally? I'm not sure what do you mean by 'the plugin' ... do you have mozplugger installed?
Comment 3 Caolan McNamara 2010-05-28 03:46:30 EDT
caolanm->dtardon: Might be the OOo firefox plugin, i.e. in Ooo enable it with tools->options->internet->browser plugin
Comment 4 Raffael Luthiger 2010-05-28 04:55:28 EDT
I was checking now in the Firefox preferences. Yes, it is mozplugger 1.12.1 handling this. It is not the plugin mentioned by Caolan. Because in OpenOffice the field he described is not checked.

When I save the DOC file I can always open it without any problems. Sadly I can not give you a specific link to a DOC file. I am connecting to a web interface of a customer's email server. And there I am often opening DOC files which are attached to emails.

The problem described here happens about every 10th time. I upgraded Fedora from 11 to 12 last weekend and this is now the first time this is happening under F12 and that's why I reported it only now.
Comment 5 Caolan McNamara 2010-05-31 11:09:40 EDT
Its clear that this is happening on OOo shutdown, thread 4 is in exit from _IceDefaultIOErrorHandler, but thread 1 is still doing something and has had the uno bridge pulled out from under it.

Given that the exit is from ICE we can't really do a lot here, we can set an alternative error handler and either exit more gracefully (well, less gracefully with a great big _exit which would avoid the inevitable crash) or a handler that doesn't do anything.
Comment 6 Caolan McNamara 2010-05-31 11:16:12 EDT
I reckon we could ignore the ioerror, I mean it should be no particular biggy if the ICE stuff goes down. Of course its part of the larger "its easier to start than stop" problem and the traffic jam will just move down the road somewhat, but one bit at a time I guess
Comment 7 Caolan McNamara 2010-05-31 16:01:47 EDT
Submitted a fix upstream. I'll think about it and see if its worth adding it into Fedora or if its so edge-case that its not worth it.
Comment 8 Caolan McNamara 2010-06-04 05:05:52 EDT
fix accepted upstream, I doubt this will fix all the problems, but it definitely fixes the immediate problem shown in the trace. Will be in >= 3.1.1-19.32
Comment 9 Caolan McNamara 2010-06-08 09:14:29 EDT
should be different 3.1.1-19.32 and not crash in the same place :-)

Note You need to log in before you can comment on or make changes to this bug.