Bug 5970 - installer fails, 'No such file or directory'
installer fails, 'No such file or directory'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-14 20:54 EDT by jenssen.peter
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 08:10:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jenssen.peter 1999-10-14 20:54:18 EDT
Tried to install RH6.1 on my home system, now running RH6.0
(xfree86 3.3.5)

Just after successfully loading aic7xxx SCSI driver:

The installer program fails with the following:

exec: No such file or directory
install exited abnormally
sending termination signals...done
sending kill signals...done
unmounting filesystems...
/mnt/source
/dev/pts
/proc
you may safely reboot your system


This occurs for expert mode as well.
If I choose not to load the SCSI driver it still happens.
Booting from CD or floppy gives the same result.
I did install, using the same CD, RH6.1 on my Compaq Armada
laptop without any problems at all.

The system:
Gigabyte BX2000 motherboard w. 128M RAM& 450MHz PIII
13 GB IDE HD, RH6.0 in top 4G, loaded with loadlin from dos.
44xSpeed CDROM (IDE primary slave)
PCI SCSI adapter: Adaptec AHA-2903
SCSI CD-RW, Yamaha 6x4x16
Matrox G400 DualHead 32MB Graphics card

RH6.0 installed without problem on this system.

Any ideas?

Thank you,
Peter Jenssen, Sydney Australia
Comment 1 Jay Turner 1999-10-21 14:45:59 EDT
This issue has been forwarded to a developer for further action.
Comment 2 cadams 1999-11-26 23:14:59 EST
I am getting the same error, however I'm getting it on any system I try.  Here's
my situation:

Since Red Hat 5.0, I've been mirroring RH, including updates.  I have a script
that then compares the versions of packages in the Red Hat tree with the updated
packages, replaces old packages with new ones, and runs genhdlist.  I
periodically build an ISO image and burn it to a CD.  I have successfully used
my CDs to install RH 5.0, 5.1, 5.2, and 6.0 (and also a couple of the beta
versions in between).

I tried this with 6.1, and the install crashes just like above.  As soon as the
CD is mounted, the installer crashes with "No such file or directory".  I have
tried using the updated boot image (with the update image) with no difference.
I can do an FTP install from my mirror, and I can even copy the files from the
CD I burned (that won't install) to a Linux partition on my hard drive and the
installer runs okay.

How is the path the installer takes different for installs from CD and installs
from a local hard drive?  I burned a couple of CDs, just assuming it would work,
and none of them do.  I've tried my CDs on SCSI CD drives, a SCSI DVD drive, IDE
CD drives, and the CD burner I made the CD on - I even copied the files off the
CD and did md5sum on each of them and compared them to the files on my mirror
and they all compared okay.

If you want to see my CD image and mirror, please email me for the FTP site (it
is not really a public mirror).  I've been using Red Hat on ISP servers since
3.0.3 and consider myself pretty familiar with it, and this is driving me crazy.
Comment 3 cadams 1999-11-29 17:00:59 EST
I think I figured out my problem - same as the others are having.

I made my CD image with both Rock Ridge and Joliet extensions, so I think I may
be having the dreaded GTK vs gtk problem.  If I just mount the CD under my
existing Linux installation, I see the files distinctly.  If I specify "norock"
then I see both names, but they both have the same contents as the GTK.py file.
If I specify "nojoliet", everything is fine.

How about making the installer do "nojoliet" when mounting a CD, since it is
guaranteed that Joliet extensions won't work anyway?
Comment 4 jenssen.peter 1999-11-29 18:41:59 EST
Well my problem is appearantly not with the CD itself, since it installed just
fine on the laptop.
The problem only occurs on my desktop system.
(could it have something to do with the fact that I have both an IDE CD-ROM and
a SCSI CD/RW?)

Also, it never got to the installation part.
It was still in the initailising part, just after choosing expert mode (or
whatever).

Peter
Comment 5 cadams 1999-11-29 20:30:59 EST
I'm still getting the "exec failed: No such file or directory"
even now that I've made a CD without Joliet extensions.

I tried to do a text install (thinking maybe the problem was just
with the GUI install) and got the same error.
Comment 6 Jay Turner 1999-11-30 08:10:59 EST
You will definitely want to confirm the contents of the cdroms that you are
installing from.  The installation works off of pressed media, as we have too
many people that say it does.  I am betting that some file or another has gotten
pushed off and therefore missing on the cdroms you are installing from.  We
already have notes to handle the error conditions a  little better in the next
release.  Please reopen this bug if you are still having problems after
confirming the contents of the cdroms you are installing from.
Comment 7 spudlink 1999-12-26 10:24:59 EST
I was able to create this situation. Due to my misunderstanding (and Redhat's
lack of documentation?) I had been incorrectly specifying details on the page
which asks for the partition and directory.
The path to my RPMS directory is /var/Redhat_6.1/i386/Redhat/RPMS. /var is on
partition /dev/hdc4. So I had been incorrectly specifying
  Partion:  /dev/hdc4
  Directory: /var/Redhat_6.1/i386
Because /dev/hdc4 represents /var the correct specification is
  Partition: /dev/hdc4
  Directory: Redhat_6.1/i386
(this is from memory)
Hope this helps some bleary eyed soul.
Now on to the next problem.

Note You need to log in before you can comment on or make changes to this bug.