Bug 597004 - KMS:R600:HD 2900 GT (2900XT?): Xorg/radeon needs nomodeset+NoDRI to start
KMS:R600:HD 2900 GT (2900XT?): Xorg/radeon needs nomodeset+NoDRI to start
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
13
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 18:01 EDT by Vile Lasagna
Modified: 2011-06-27 12:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 12:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from my current working configuration (radeon, nomodeset, NoDRI) (152.59 KB, text/plain)
2010-05-27 18:01 EDT, Vile Lasagna
no flags Details
dmesg from a boot with "radeon.modeset=1 drm.debug=15 3" (89.18 KB, text/plain)
2010-05-27 18:39 EDT, Vile Lasagna
no flags Details
Xorg.0.log from a boot with "radeon.modeset=1 drm.debug=15 3" (120.06 KB, text/plain)
2010-05-27 18:40 EDT, Vile Lasagna
no flags Details

  None (edit)
Description Vile Lasagna 2010-05-27 18:01:19 EDT
Created attachment 417402 [details]
Xorg.0.log from my current working configuration (radeon, nomodeset, NoDRI)

Description:

When using the radeon xorg driver, boot freezes completely (Ctrl+Alt+Del won't work). This happens with or without the nomodeset flag, resulting in a blank screen (there's a black cursor on when the flag is set). Adding the option "NoDRI" to xorg.conf makes the driver work, but only if using nomodeset. Tried also installing and using the "radeonhd" driver. With nomodeset, the screen freezes with artefacts derived from the standard blue fedora background, as soon as X starts. Without it, the driver works normally, although performance seems to be worse than when using vesa, which works fine.
In all working solutions and configurations so far, there was no 3D acceleration.

Also tried the solution proposed in this page. Still getting the same blank screen (http://fedorasolved.org/video-solutions/radeon-xorg-tweaks/?searchterm=radeon)
 

Version-Release number of selected component (if applicable):

6.13.0-1.fc13(x86_64)


How reproducible:

Happens every time in my machine (Phenom 9500, ASUS M3A32MVP-Deluxe, Sapphire Radeon 2900XT), other instances unknown.

Steps to Reproduce:
1.Happens straight on from a live fedora CD, or from an installation using standard drivers
2.Has been observed after installing SuSE 11.2(x86_64), though I "ragequitted" and decided to try fedora out before digging deeper there, never got to actually boot into that SuSE 
  
Actual results:

Using vesa works, as well as using radeonhd IF allowing kernel modesetting.
Best results with radeon driver so far was disabling modesetting and using "NoDRI" in xorg.conf. There is, however, no 3D acceleration in this case


Additional info:
Comment 1 François Cami 2010-05-27 18:10:57 EDT
Could you boot with the following kernel parameters:
drm.debug=15 radeon.modeset=1 3
and attach /var/log/dmesg to that bug (text/plain please)?
Comment 2 Vile Lasagna 2010-05-27 18:39:24 EDT
Created attachment 417413 [details]
dmesg from a boot with "radeon.modeset=1 drm.debug=15 3"
Comment 3 Vile Lasagna 2010-05-27 18:40:05 EDT
Created attachment 417414 [details]
Xorg.0.log from a boot with "radeon.modeset=1 drm.debug=15 3"
Comment 4 François Cami 2010-05-27 18:49:48 EDT
Switching assignee to jglisse, and upping prio/sev because:
* the fix for this is not easy to find for the average user
* reporter has no 3D no matter what
Comment 5 Vile Lasagna 2010-05-27 18:50:06 EDT
Comment on attachment 417414 [details]
Xorg.0.log from a boot with "radeon.modeset=1 drm.debug=15 3"

wrong log
Comment 6 François Cami 2010-05-27 19:05:48 EDT
From reporter (IRC): starting Xorg, after booting with "radeon.modeset=1 drm.debug=15 3" results in a hard crash (no ssh).
Setting as triaged.
Comment 7 Bug Zapper 2011-06-02 09:10:12 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Bug Zapper 2011-06-27 12:51:32 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.