Bug 59701 - Xconfigurator didn't work for ATI Radeon M6 LY w/8mb memory
Xconfigurator didn't work for ATI Radeon M6 LY w/8mb memory
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-11 16:29 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 16:31:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the XF86Config file that worked with the 8bm memory, that I edited. (2.08 KB, text/plain)
2002-02-11 16:31 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-02-11 16:29:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1

Description of problem:
We got working an ATI Radeon M6 LY w/16mb of video memory (on an A30 ThinkPad),
then switched the hard drive to the same model ThinkPad with 8mb memory and it
didn't work.

So I ran Xconfigurator, and it detected ATI Radeon M6 LY, and I entered 8bm
memory and selected generic laptop panel at 1400x1050.  It couldn't start the
server.  We tried selecting all the different panels, we tried putting 16mb and
4mb of memory, and it wouldn't work.  Finally I looked around and manually added
"VideoRam 8192" to the device section for the ATI card in the XF86Config and it
worked.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I only had two computers to work on, an ATI Radeon M6 LY w/16mb memory and an
8mb one.  

I ran XConfigurator on the 16mb one, and it worked.
I ran Xconfigurator on the 8bm one, selecting  1400x1050 laptop panel and 8mb
memory and checking most of the modes (except 1600x1200), and it didn't work.
	

Actual Results:  Xconfigurator flashed a couple of times, then said there was a
problem, and gave me options of back and quit.  startx didn't work after that.

Expected Results:  When you select 8mb ram, it should automatically add the line
"VideoRam 8192" to the device section for the ATI card, which is what made it
work when I added it manually.

Additional info:
Comment 1 Need Real Name 2002-02-11 16:31:36 EST
Created attachment 45320 [details]
This is the XF86Config file that worked with the 8bm memory, that I edited.
Comment 2 Mike A. Harris 2002-02-12 13:57:12 EST
The ATI Radeon Mobility is not supported by XFree86 4.1.0.  I added
some patches to XFree86 from ATI so that the hardware _might_ work, but
it's only there as a convenience to our users in hopes that it works
for them.  The Radeon Mobility is not officially supported in 7.2.

Full Radeon Mobility support is available in XFree86 4.2.0 however in
rawhide, so you may want to upgrade to the rawhide packages if you have
any problems with 4.1.0.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.