Bug 597067 - NumberFormatException: For input string: "" in JBossSoftwareContentSourceAdapter.initialize
Summary: NumberFormatException: For input string: "" in JBossSoftwareContentSourceAda...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
(Show other bugs)
Version: 1.3.1
Hardware: All Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: John Mazzitelli
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon3
TreeView+ depends on / blocked
 
Reported: 2010-05-28 03:56 UTC by Ondřej Žižka
Modified: 2014-05-29 18:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 18:14:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log snippet (11.80 KB, text/plain)
2010-05-28 04:04 UTC, Ondřej Žižka
no flags Details

Description Ondřej Žižka 2010-05-28 03:56:13 UTC
Version-Release number of selected component (if applicable):
JON 2.3.0

Steps to Reproduce:

1. Create a CSP Content source with 
  https://support.stage.redhat.com/jbossnetwork/restricted/feed/software.html?product=appplatform&downloadType=patches&flavor=rss&version=&jonVersion=2.0
  anr appropriate credentials 

2. tail -f rhq-server/logs/...

3. Click Test / Synchronize

4. See the exception in the log
  

Stack trace attached.

Comment 1 Ondřej Žižka 2010-05-28 04:04:33 UTC
Created attachment 417461 [details]
log snippet

Comment 2 Ondřej Žižka 2010-05-28 04:58:24 UTC
This is probably caused by an attempt to parse an empty Proxy Settings, which values are not set as unset by default.

So, 
first fix the NPE (validate proxy values properly), 
then set those values as unset by default.

Comment 3 Ondřej Žižka 2010-07-02 20:48:44 UTC
Steps to reproduce, should happen every time:

1) Create a CSP account, but ommit the Name field. JON will complain.
2) Fill the Name. And submit. JON will eat this.
3) tail -f -n 1000 log ,  and see the attached exception there.

Comment 4 Simeon Pinder 2010-07-02 21:00:43 UTC
Looks like we're not checking or enforcing that the name field is filled in when it obviously must be and we're assuming that it already filled in in the code.

Need to add required field check in UI and double check in code to prevent using bad data.


Note You need to log in before you can comment on or make changes to this bug.