Bug 59711 - scsi boot device and usb storage device conflict
scsi boot device and usb storage device conflict
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-11 19:45 EST by greg hosler
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description greg hosler 2002-02-11 19:45:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13smp-MO i686; Nav)

Description of problem:
If your system has a scsi boot device, eventually there will be an initrd image
which will cause the scsi devices to be numbered (from a), upon boot (this is
post installation).
The problem (during installation) is that if you have a usb storage device that
happens to be plugged in, then the usb probe (which happens _before_ the scsi
probe) will see the usb device, and number that device as "sda". Later on, once
you get into disk druid, your scsi devices will be numberes with the usb_storage
device as sda, and your 1st scsi device as "sdb" - this does not reflect a post
install configuration, as
post-install, the initrd will generally force the scsi devices to number from
"sda".

It seems that there could be significant problems getting a system
booted/running after the installation, due to the mis-numbering. (e2labels will
forgive alot of problems, but there is always tle lilo.conf/grub.conf file,
which will be wrong).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. plug a usb-storage device into the usb port. (e.g. a san-disk reader)
2. boot the red hat installer
3. go to dusk druid. observe that the disk layout begins from sdb
	

Expected Results:  the scsi disks should have been labeled first, and the
usb-storage should have been labeled after the scsi devices.

Additional info:

I think that by moving the usb probe to after the scsi probe, this will
circumvent the situation.
Comment 1 Michael Fulbright 2002-02-12 12:48:20 EST
Thought we fixed this already - jeremy?
Comment 2 Jeremy Katz 2002-02-12 14:16:24 EST
This should be happening already unless it broke merging to head...  I'll have
to check a bit later
Comment 3 Jeremy Katz 2002-02-28 16:08:56 EST
Bleah, broken by dropping rmmod support from the loader modutils.  notting's
working on it
Comment 4 Jeremy Katz 2002-02-28 22:03:49 EST
Fixed
Comment 5 Red Hat Bugzilla 2006-02-21 13:48:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.