Bug 597118 - A warning should be given in the help of mke2journal-L for the length of label
A warning should be given in the help of mke2journal-L for the length of label
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
: 597116 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 03:24 EDT by Yufang Zhang
Modified: 2011-07-14 15:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 15:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yufang Zhang 2010-05-28 03:24:50 EDT
Description of problem:
For the mke2journal-L, label is limited to 16 bytes. So if you set label longer than that length, it will be truncated. Thus the label set may not be as what you expect. So it is better to add some warning in the help of mke2journal-L to let people know this limitation. 

Version-Release number of selected component (if applicable):
major: 1
minor: 2
release: 7
extra: 


How reproducible:
Always

Steps to Reproduce:
1.><fs> mke2journal-L 1024 "1234567890abcdefg" /dev/VG/jounal
  
2.><fs> get-e2label /dev/VG/jounal
1234567890abcdef

  
Actual results:


Expected results:
At least a warning should be given in the help to inform people this limitation.

Additional info:
Comment 1 Yufang Zhang 2010-05-28 04:51:38 EDT
*** Bug 597116 has been marked as a duplicate of this bug. ***
Comment 2 Richard W.M. Jones 2010-06-01 10:41:56 EDT
Confirmed from the Linux sources that the volume name is
limited to 16 bytes, even for ext4.
Comment 3 Richard W.M. Jones 2010-06-01 10:44:56 EDT
Confirmed also that Linux swap labels are 16 bytes long.
Comment 4 Richard W.M. Jones 2010-06-01 11:21:45 EDT
Patch posted upstream:
https://www.redhat.com/archives/libguestfs/2010-June/msg00011.html
Comment 5 Fedora Update System 2010-06-02 17:12:32 EDT
libguestfs-1.2.9-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.9-1.el5
Comment 6 Fedora Update System 2010-06-02 17:26:19 EDT
libguestfs-1.2.9-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.9-1.fc13
Comment 7 Richard W.M. Jones 2010-06-02 17:32:59 EDT
This patch has been pushed upstream.

If this needs to be fixed for RHEL 5 / 6, please clone
this bug and adjust the Product accordingly.
Comment 8 Fedora Update System 2010-06-03 04:49:01 EDT
libguestfs-1.2.9-1.el5.1 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.9-1.el5.1

Note You need to log in before you can comment on or make changes to this bug.