Bug 597124 - system became unbootable after yum update
Summary: system became unbootable after yum update
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 07:42 UTC by Lubos Kocman
Modified: 2010-06-14 21:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 21:46:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lubos Kocman 2010-05-28 07:42:35 UTC
Description of problem:

I installed latest snapshot of RHEL6.0 Workstation (20100526) on Thinkpad X60 (i686). System booted up normally. After yum update and reboot system hanged after self test and no grub appeared (only black screen with blinking cursor).

------------------------------------------------------------------------------

I solved the situation by booting RHEL 6 install media over pxe, chrooting and grub-install /dev/sda. 

So it means that grub wasn't correctly written in MBR

-------------------------------------------------------------------------------
Version-Release number of selected component (if applicable):

grub-7.0.15-1.el6.i686
yum-3.2.27-9.el6.noarch

How reproducible:

Steps to Reproduce:
1. Take an i686 machine

2.Install one of latest nightly build of RHEL 6 (20100526 in my case) over pxe boot. Leave /boot on separate primary partition with ext4 filesystem.

3. yum -y update

4. reboot
  
Actual results:

System will no longer be bootable


Expected results:

Grub will be correctly written in MBR and system will be bootable


Additional info:

I don't think that this will help but used hard drive is a SSD.

Comment 3 RHEL Product and Program Management 2010-06-07 16:02:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Peter Jones 2010-06-14 21:46:49 UTC
grub's stages 1 and 2 are not updated during a package upgrade; this cannot be the cause for the system becoming unbootable.


Note You need to log in before you can comment on or make changes to this bug.