Bug 597134 - yum openjdk dependency problems
Summary: yum openjdk dependency problems
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 08:15 UTC by Frederic Hornain
Modified: 2010-05-29 11:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-29 11:53:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frederic Hornain 2010-05-28 08:15:15 UTC
Description of problem:
Have a fresh updated FC13.
Then I have tried to install java-1.6.0-openjdk-devel.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64

How reproducible:
See below

Steps to Reproduce:
1. yum clean all
2. yum update
3. yum install java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64
  
Actual results:
yum install java-1.6.0-openjdk-devel
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-37.b17.fc13 set to be updated
--> Processing Dependency: java-1.6.0-openjdk = 1:1.6.0.0-37.b17.fc13 for package: 1:java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64
--> Processing Dependency: netbeans-platform for package: 1:java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64
--> Running transaction check
---> Package java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-37.b17.fc13 set to be updated
--> Processing Dependency: java-1.6.0-openjdk = 1:1.6.0.0-37.b17.fc13 for package: 1:java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64
---> Package netbeans-platform.noarch 0:6.8-2.fc13 set to be updated
--> Processing Dependency: swing-layout >= 1.0 for package: netbeans-platform-6.8-2.fc13.noarch
--> Processing Dependency: javahelp2 >= 2.0.05 for package: netbeans-platform-6.8-2.fc13.noarch
--> Running transaction check
---> Package java-1.6.0-openjdk-devel.x86_64 1:1.6.0.0-37.b17.fc13 set to be updated
--> Processing Dependency: java-1.6.0-openjdk = 1:1.6.0.0-37.b17.fc13 for package: 1:java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64
---> Package javahelp2.noarch 0:2.0.05-8.fc12 set to be updated
---> Package swing-layout.x86_64 0:1.0.4-1.fc13 set to be updated
--> Finished Dependency Resolution
Error: Package: 1:java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64 (fedora)
           Requires: java-1.6.0-openjdk = 1:1.6.0.0-37.b17.fc13
           Installed: 1:java-1.6.0-openjdk-1.6.0.0-38.b18.fc13.x86_64 (@updates-testing)
           Available: 1:java-1.6.0-openjdk-1.6.0.0-37.b17.fc13.x86_64 (fedora)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
java-1.6.0-openjdk-devel-1.6.0.0-37.b17.fc13.x86_64 and its dependency should be installed correctly.

Additional info:

Comment 1 Andre Robatino 2010-05-29 06:55:37 UTC
>            Installed: 1:java-1.6.0-openjdk-1.6.0.0-38.b18.fc13.x86_64
> (@updates-testing)

It looks like you have a newer updates-testing version.  Try

yum downgrade java-1.6.0-openjdk

to get the current F13 version (java-1.6.0-openjdk-1.6.0.0-37.b17.fc13).

Comment 2 Frederic Hornain 2010-05-29 11:53:58 UTC
Thanks a lot.
That was the solution.
Thanks again.
BR
Frederic ;)


Note You need to log in before you can comment on or make changes to this bug.