Bug 597191 - RFE: write /dev/disk/by-path paths to /boot/grub/device.map
RFE: write /dev/disk/by-path paths to /boot/grub/device.map
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Peter Jones
Release Test Team
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 06:36 EDT by Hans de Goede
Modified: 2010-08-20 17:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 17:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-05-28 06:36:25 EDT
When a usb stick is plugged in during installation, it now often becomes sda
(since the usb mass storage scanning delay was reduced). This results in a means /boot/grub/device.map getting writting which contains:
(hd0) /dev/sdb

If the user then later needs to re-install grub and uses the device.amp, without the usb stick present. Things go wrong.

As /dev/sdx names are not really stable it would be much better to write
/dev/disk/by-path/... paths to device.map .
Comment 2 Peter Jones 2010-08-20 17:08:21 EDT
/dev/disk/by-path/ for that is a really bad idea - disk paths change sometimes when new pci devices are installed due to pci enumeration weirdness.

Note You need to log in before you can comment on or make changes to this bug.