Bug 597227 - Dashed Lines Off Clip Can Black Out Graphics
Dashed Lines Off Clip Can Black Out Graphics
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
5.5
i386 Linux
low Severity high
: rc
: ---
Assigned To: Denis Lila
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 09:07 EDT by harry.kantor
Modified: 2010-11-30 09:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 09:35:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test file to reproduce bug (1.23 KB, text/x-java)
2010-05-28 09:07 EDT, harry.kantor
no flags Details
This fixes it. (6.90 KB, patch)
2010-06-16 09:23 EDT, Denis Lila
no flags Details | Diff

  None (edit)
Description harry.kantor 2010-05-28 09:07:13 EDT
Created attachment 417597 [details]
Test file to reproduce bug

Description of problem:


Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-1.11.b16.el5


How reproducible:

Run the test file with OpenJDK.  When the frame is displayed, press the "button".  The background will fill completely to black.

The following test file:



Steps to Reproduce:
1. Compile and run the code with OpenJDK.
2. Press the "button".
3. Compile and run the code with Sun's JDK
4) Press the "button"
  
Actual results:

With OpenJDK, the entire panel is drawn in black.


Expected results:

With Sun's JDK (1.6_20), there are only a few dashed lines are drawn.
Comment 1 Denis Lila 2010-06-16 09:23:24 EDT
Created attachment 424442 [details]
This fixes it.

The problem was overflows in pisces/Dasher.java, pisces/PiscesMath.java, and pisces/Stroker.java.

I think I fixed them all.

I submitted this patch to the openjdk7 2d-dev mailing list, and am still waiting to hear back from them.

Note You need to log in before you can comment on or make changes to this bug.