Bug 59724 - major issues with rxvt in RHL 7.2
major issues with rxvt in RHL 7.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rxvt (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-11 23:31 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-19 06:54:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen cap showing problem 1 (6.03 KB, image/png)
2002-02-11 23:35 EST, Need Real Name
no flags Details
Screen cap showing problem 2 (5.83 KB, image/png)
2002-02-11 23:36 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-02-11 23:31:23 EST
I am having a variety of different issues in rxvt. Before RHL 7.2, I've never
seen any of these problems before, and I've used rxvt for 4-5 years. Perhaps
it's due to the fact you shipped a development version.

1) On terminals, after a while, I get bold dashes along the left side. I will
attach a screep cap showing them. This is an abnormally wide rxvt, but I get it
on 80x24 terminals as well, in the default font. ^L to refresh gets rid of the
glitch. It starts out with just one 'dash' at the bottom-right. Then they
multiply as the terminal scrolls, until it's on every line along the right.

2) graphical glitches when running mutt inside rxvt. Probably due to a bad
termcap or terminfo entry. I will attach a screen cap of this as well. The
"Attachments" and "Mutt: Compose" white bar is supposed to extend the whole
width of the terminal.

3) I can't paste characters in the range of 128-255 into rxvt from other
applications. If I start up an xterm, the paste works fine.

4) I can't paste into rxvt from 'xpdf' *at all*. xterm recieves the paste fine.

This was with a fully up2date box. 2, 3, and 4 were fully reproducable over the
last months. 1 seems to happen at completely random times. It happens in my
syslog and IRC terminals mostly, but in others as well. Likely in those two as
they scroll more then the "normal" usage terminals.

I removed the rxvt package that Red Hat installed, and compiled my own copy with
the sources off of rxvt.org, version 2.6.4 (latest stable). All four problems
went away.
Comment 1 Need Real Name 2002-02-11 23:35:52 EST
Created attachment 45359 [details]
Screen cap showing problem 1
Comment 2 Need Real Name 2002-02-11 23:36:10 EST
Created attachment 45360 [details]
Screen cap showing problem 2
Comment 3 Harald Hoyer 2002-07-09 11:02:29 EDT
sorry... retry with rxvt from 7.3

Note You need to log in before you can comment on or make changes to this bug.