Bug 597253 - Update cluster.ng
Update cluster.ng
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
low Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Cluster QE
:
: 454403 530940 (view as bug list)
Depends On:
Blocks: 597258
  Show dependency treegraph
 
Reported: 2010-05-28 10:00 EDT by Marek Grac
Modified: 2011-02-16 11:14 EST (History)
5 users (show)

See Also:
Fixed In Version: system-config-cluster-1.0.56-7.el4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 597258 (view as bug list)
Environment:
Last Closed: 2011-02-16 11:14:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0267 normal SHIPPED_LIVE system-config-cluster bug fix update 2011-02-16 11:12:12 EST

  None (edit)
Description Marek Grac 2010-05-28 10:00:48 EDT
Hello Juha,

You wrote:
> While the actual fix appears to work fine, there is a problem with
validating the cluster.conf with the newly added power_wait atttibute:

Indeed, the schema used in validation is part of the system-config-cluster
package which was not refreshed as part of the hotfix. To have it recognise
the new attribute, it would need a patch similar to the following:

--- ./src/misc/cluster.ng.orig 2010-03-10 16:02:40.899864461 +0100
+++ ./src/misc/cluster.ng 2010-03-10 16:08:29.717864438 +0100
@@ -98,6 +98,9 @@
         <optional>
          <attribute name="force"/>
         </optional>
+        <optional>
+         <attribute name="power_wait"/>
+        </optional>
        </group>
        <!-- GNBD -->
        <group>
Comment 1 Lon Hohberger 2010-10-22 16:57:59 EDT
cluster.ng is missing the optional "cmd_prompt" attribute for the fencedevice element.  This is noted in bug 530940.
Comment 2 Lon Hohberger 2010-10-22 16:59:34 EDT
*** Bug 530940 has been marked as a duplicate of this bug. ***
Comment 3 Ryan McCabe 2010-10-25 11:13:05 EDT
*** Bug 454403 has been marked as a duplicate of this bug. ***
Comment 6 errata-xmlrpc 2011-02-16 11:14:04 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0267.html

Note You need to log in before you can comment on or make changes to this bug.