Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 597262 - [RHEL6]: Crash in khugepaged
[RHEL6]: Crash in khugepaged
Status: CLOSED DUPLICATE of bug 612217
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 10:20 EDT by Chris Lalancette
Modified: 2010-07-12 19:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 19:15:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2010-05-28 10:20:57 EDT
Description of problem:
I'm running RHEL-6 as a KVM guest on a RHEL-6 host.  One of the times I tried to boot my RHEL-6 guest, I got the following backtrace and crash:

HugeTLB registered 2 MB page size, pre-allocated 0 pages
------------[ cut here ]------------
kernel BUG at mm/huge_memory.c:2044!
invalid opcode: 0000 [#1] SMP 
last sysfs file: 
CPU 1 
Modules linked in:
Pid: 84, comm: khugepaged Not tainted 2.6.32-28.el6.x86_64 #1 Bochs
VFS: Disk quotas dquot_6.5.2
RIP: 0010:[<ffffffff8115c793>] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
 [<ffffffff8115c793>] khugepaged+0xb63/0x1100
RSP: 0018:ffff88020123fd90  EFLAGS: 00010203
msgmni has been set to 15180
RAX: ffff880201184080 RBX: ffff8802051addc0 RCX: 000000000000045c
SELinux:  Registering netfilter hooks
RDX: 0000000000000001 RSI: 0000000000000282 RDI: 0000000000000282
RBP: ffff88020123fee0 R08: ffff880028256228 R09: 0000000000000000
R10: 0000000000000000 R11: 0000000000000001 R12: ffff88020123fef8
R13: ffffffff8115bc30 R14: 0000000000000000 R15: 0000000000000001
FS:  0000000000000000(0000) GS:ffff880028240000(0000) knlGS:0000000000000000
alg: No test for stdrng (krng)
ksign: Installing public key data
Loading keyring
- Added public key 5E7692C011CB000E
- User ID: Red Hat, Inc. (Kernel Module GPG key)
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
CR2: 0000000000000000 CR3: 0000000001001000 CR4: 00000000000006e0
io scheduler cfq registered (default)
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process khugepaged (pid: 84, threadinfo ffff88020123e000, task ffff880201184080)
Stack:
 0000000000000000 ffff8800282561f0 ffff880028256180 0000000000000000
<0> ffff88020123fe10 ffffffff810116e0 ffff88020123fdd0 ffff880201184080
<0> ffffffff81767180 ffff880201184080 ffff88020123e000 ffffffff81056c68
Call Trace:
 [<ffffffff810116e0>] ? __switch_to+0xd0/0x320
 [<ffffffff81056c68>] ? finish_task_switch+0x48/0xe0
 [<ffffffff814cb58e>] ? thread_return+0x4e/0x750
 [<ffffffff81059382>] ? default_wake_function+0x12/0x20
 [<ffffffff8115bc30>] ? khugepaged+0x0/0x1100
 [<ffffffff8108dac6>] kthread+0x96/0xa0
 [<ffffffff810141ca>] child_rip+0xa/0x20
 [<ffffffff8108da30>] ? kthread+0x0/0xa0
 [<ffffffff810141c0>] ? child_rip+0x0/0x20
Code: ff ff ff 01 8b bd 38 ff ff ff 3b 3d 3c f7 74 00 0f 87 6f 04 00 00 48 83 c3 08 48 81 85 60 ff ff ff 00 10 00 00 eb bd 0f 0b eb fe <0f> 0b eb fe 31 db 41 bc 01 00 00 00 90 e9 8f f8 ff ff 48 8b 40 
RIP  [<ffffffff8115c793>] khugepaged+0xb63/0x1100
 RSP <ffff88020123fd90>
---[ end trace 57f7151f6a5def05 ]---
Kernel panic - not syncing: Fatal exception
Pid: 84, comm: khugepaged Tainted: G      D    2.6.32-28.el6.x86_64 #1
Call Trace:
 [<ffffffff814cae34>] panic+0x78/0x137
 [<ffffffff814ceedc>] oops_end+0xdc/0xf0
 [<ffffffff8101725b>] die+0x5b/0x90
 [<ffffffff814ce794>] do_trap+0xc4/0x160
 [<ffffffff8115bc30>] ? khugepaged+0x0/0x1100
 [<ffffffff81014ec5>] do_invalid_op+0x95/0xb0
 [<ffffffff8115c793>] ? khugepaged+0xb63/0x1100
 [<ffffffff81059636>] ? update_curr+0xe6/0x1d0
 [<ffffffff81013f5b>] invalid_op+0x1b/0x20
 [<ffffffff8115bc30>] ? khugepaged+0x0/0x1100
 [<ffffffff8115c793>] ? khugepaged+0xb63/0x1100
 [<ffffffff810116e0>] ? __switch_to+0xd0/0x320

(it got a bit truncated due to a reboot, but that is most of it)

Version-Release number of selected component (if applicable):
kernel-2.6.32-28.el6.x86_64
qemu-kvm-0.12.1.2-2.68.el6.x86_64 (with the nohpet patch applied from http://post-office.corp.redhat.com/archives/rhvirt-patches/2010-May/msg01210.html)

How reproducible:
Only once so far.

Steps to Reproduce:
1.  Boot a RHEL-6 KVM guest on a RHEL-6 host
  
Actual results:
Crash in khugepaged

Expected results:
Successful boot.

Additional info:
Comment 2 RHEL Product and Program Management 2010-06-07 12:05:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Andrea Arcangeli 2010-07-12 19:15:34 EDT

*** This bug has been marked as a duplicate of bug 612217 ***

Note You need to log in before you can comment on or make changes to this bug.