Bug 597298 - update to version 0.7
Summary: update to version 0.7
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gedit-vala   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Michel Alexandre Salim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 15:34 UTC by Paul Lange
Modified: 2010-09-21 10:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-21 10:26:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Lange 2010-05-28 15:34:16 UTC
In F13 when trying to create a new project the plugins crashes. Please update to the most recent version.

Comment 1 Michel Alexandre Salim 2010-09-21 09:31:20 UTC
I could push a 0.7 update for F-13, but that would be the only newer version that does not require vala >= 0.9.5 (with the soname change).

Another option is to get gedit-valencia reviewed -- it's more light-weight and the current release works on the pre-soname-bump F-13 version of vala.

https://bugzilla.redhat.com/show_bug.cgi?id=518892

Comment 2 Michel Alexandre Salim 2010-09-21 10:26:52 UTC
Can't be fixed, I'm afraid. We have vala 0.9.3 in F-12 and F-13. The first vtg
(gedit-vala) release that supports this is 0.8.0, but that would require an
update to gtksourceview2. We also cannot update to the 0.10.x series of vtg
because that depends on vala >= 0.9.5 and that introduces an soname bump that
would require other packages to be updated.

I recommend getting gedit-valencia reviewed and using that for F-12 and F-13
instead of gedit-vala:

https://bugzilla.redhat.com/show_bug.cgi?id=518892

I've tested several scenarios that crashes gedit-vala and valencia works fine
in those.


Note You need to log in before you can comment on or make changes to this bug.