Bug 59732 - DRI not set up on Voodoo3 card
DRI not set up on Voodoo3 card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-12 07:57 EST by Wade Minter
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-12 19:07:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "startx >x.log 2>&1" (2.53 KB, text/plain)
2002-02-12 19:04 EST, Wade Minter
no flags Details
/etc/X11/XF86Config-4 (3.72 KB, text/plain)
2002-02-12 19:05 EST, Wade Minter
no flags Details

  None (edit)
Description Wade Minter 2002-02-12 07:57:07 EST
Description of Problem:

Using Hampton Beta 1.

I have a Voodoo3 3000 card in my machine.  X configuration proceeds normally,
but when I run "glxinfo" upon logging in as a user, I get:

[minter@kenbridge minter]$ glxinfo | grep -i direct
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
[minter@kenbridge minter]$

Should DRI be set up on cards that can use it?
Comment 1 Mike A. Harris 2002-02-12 14:02:24 EST
Yes, DRI is enabled by default for all hardware that supports it.
The Voodoo 3 only supports DRI at 16bit depth, and only if you're
using 1024x768 or lower.

Please attach your X config files and X server log as file attachments
to all XFree86/Xconfigurator bug reports.  Also, just a note for future,
XFree86-Servers is XFree86 3.3.6, and is not part of the beta, it is
obsoleted from the distro now.

Thanks
Comment 2 Wade Minter 2002-02-12 19:04:47 EST
Created attachment 45459 [details]
Output of "startx >x.log 2>&1"
Comment 3 Wade Minter 2002-02-12 19:05:31 EST
Created attachment 45460 [details]
/etc/X11/XF86Config-4
Comment 4 Wade Minter 2002-02-12 19:07:17 EST
Ok.  I've attached the X startup log and XF86Config-4.

I set up 16 bit color and 1024x768 during the install.
Comment 5 Mike A. Harris 2002-03-14 09:44:16 EST
This I believe is due to a bug in anaconda putting pex and xie modules
into the config file, which no longer exist.  Comment out these lines,
and it should work. If not, it definitely works in the latest release,
as I am testing a Voodoo 3 with DRI in 1024x768 right now.

4.2.0-6.45 should work fine.

Note You need to log in before you can comment on or make changes to this bug.