Bug 597354 - [abrt] crash in drumstick-examples-0.2.99-0.3.20100208svn.fc12: raise: Process /usr/bin/drumstick-sysinfo was killed by signal 6 (SIGABRT)
[abrt] crash in drumstick-examples-0.2.99-0.3.20100208svn.fc12: raise: Proces...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: drumstick (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
abrt_hash:bed4b49fde94c408716a1f4ee43...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 13:49 EDT by Niels Mayer
Modified: 2010-06-07 18:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: drumstick-0.3.1-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 18:25:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.81 KB, text/plain)
2010-05-28 13:49 EDT, Niels Mayer
no flags Details
File: comment (3.95 KB, text/plain)
2010-05-28 13:49 EDT, Niels Mayer
no flags Details

  None (edit)
Description Niels Mayer 2010-05-28 13:49:00 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: drumstick-sysinfo
Attached file: comment
component: drumstick
crash_function: raise
executable: /usr/bin/drumstick-sysinfo
global_uuid: bed4b49fde94c408716a1f4ee43c5c1627c6af5a
kernel: 2.6.32.12-115.fc12.x86_64
package: drumstick-examples-0.2.99-0.3.20100208svn.fc12
rating: 4
reason: Process /usr/bin/drumstick-sysinfo was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Have Jack Running, with MIDI connections to some ALSA devices.
2. run 'drumstick-sysinfo'
3. core dump. 

Note:

gnulem-31-~> aplaymidi -l
 Port    Client name                      Port name
 14:0    Midi Through                     Midi Through Port-0
 28:0    MT4                              MT4 MIDI 1
 28:1    MT4                              MT4 MIDI 2
 28:2    MT4                              MT4 MIDI 3
 28:3    MT4                              MT4 MIDI 4
 28:4    MT4                              MT4 Broadcast
 32:0    BCD3000                          BCD3000 MIDI 1
 36:0    UM-2                             UM-2 MIDI 1
 36:1    UM-2                             UM-2 MIDI 2

gnulem-9-~/Documents>  cat /proc/asound/seq/timer
Timer for queue 0 : system timer
  Period time : 0.001000000
  Skew : 65536 / 65536
gnulem-10-~/Documents> cat /proc/asound/timers
G0: system timer : 1000.000us (10000000 ticks)
  Client sequencer queue 0 : running
P0-0-0: PCM playback 0-0-0 : SLAVE
P0-0-1: PCM capture 0-0-1 : SLAVE
P1-0-0: PCM playback 1-0-0 : SLAVE
P1-0-1: PCM capture 1-0-1 : SLAVE
P1-0-2: PCM playback 1-0-2 : SLAVE
P1-0-3: PCM capture 1-0-3 : SLAVE
P1-1-0: PCM playback 1-1-0 : SLAVE
P2-0-0: PCM playback 2-0-0 : SLAVE
P2-0-1: PCM capture 2-0-1 : SLAVE
P4-0-0: PCM playback 4-0-0 : SLAVE
  Client application 2396 : stopped
  Client application 2642 : stopped
  Client application 2654 : running
P4-0-1: PCM capture 4-0-1 : SLAVE
Comment 1 Niels Mayer 2010-05-28 13:49:02 EDT
Created attachment 417703 [details]
File: backtrace
Comment 2 Niels Mayer 2010-05-28 13:49:03 EDT
Created attachment 417704 [details]
File: comment
Comment 3 Niels Mayer 2010-05-28 15:52:22 EDT
Forgot to mention, I'm using jack2 from CCRMA repository:
jack-audio-connection-kit-devel-1.9.4-1.fc12.ccrma.x86_64

The exact same thing happening on different machine when just running jackd on its own. No core dump when jackd isn't running....

coggie-30-~> cat .jackdrc
/usr/bin/jackd -dalsa -dhw:ICE1724 -r48000 -p128 -n2 -D -Pmulti -Xseq -zs -H -M

coggie-26-~> `cat .jackdrc` &
[1] 16996
coggie-27-~> jackdmp 1.9.4
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2009 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 60
audio_reservation_init
Acquire audio card Audio6
creating alsa driver ... multi|hw:ICE1724|128|2|48000|0|0|hwmon|hwmeter|-|32bit
Using ALSA driver ICE1724 running on card 6 - ICEnsemble ICE1724 at 0xe400, irq 19
configuring for 48000Hz, period = 128 frames (2.7 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 32bit integer little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 32bit integer little-endian
ALSA: use 2 periods for playback
port created: Midi-Through:midi/playback_1
port created: Midi-Through:midi/capture_1
port created: MT4:midi/playback_1
port created: MT4:midi/capture_1
port created: MT4:midi/playback_2
port created: MT4:midi/capture_2
port created: MT4:midi/playback_3
port created: MT4:midi/capture_3
port created: MT4:midi/capture_4
port created: MT4:midi/capture_5
port created: LPK25:midi/playback_1
port created: LPK25:midi/capture_1
port created: DJ-Console-(WE):midi/playback_1
port created: DJ-Console-(WE):midi/capture_1
port created: ICEnsemble-ICE1724:midi/playback_1
port created: ICEnsemble-ICE1724:midi/capture_1

coggie-27-~> drumstick-sysinfo
ALSA Sequencer System Info
Compiled ALSA library: 1.0.22
Runtime ALSA library: 1.0.23
Runtime ALSA drivers: 1.0.21.
Numeric ALSA compiled library: 10016
Numeric ALSA runtime library: 10017
Numeric ALSA runtime driver: 10015
Max Clients: 192
Max Ports: 256
Max Queues: 8
Max Channels: 256
Current Queues: 1
Current Clients: 8

ALSA Timers
type__ Name________________ c/s/C/D/S Freq.
system system timer         1/0/0/0/0 1000 Hz
PCM    PCM playback 0-0-0   3/0/0/0/0 SLAVE
PCM    PCM capture 0-0-1    3/0/0/0/1 SLAVE
PCM    PCM playback 0-0-2   3/0/0/0/2 SLAVE
PCM    PCM capture 0-0-3    3/0/0/0/3 SLAVE
PCM    PCM playback 0-1-0   3/0/0/1/0 SLAVE
PCM    PCM playback 0-3-0   3/0/0/3/0 SLAVE
PCM    PCM playback 1-0-0   3/0/1/0/0 SLAVE
PCM    PCM capture 1-0-1    3/0/1/0/1 SLAVE
PCM    PCM playback 4-0-0   3/0/4/0/0 SLAVE
PCM    PCM capture 4-0-1    3/0/4/0/1 SLAVE
PCM    PCM capture 5-0-1    3/0/5/0/1 SLAVE
PCM    PCM playback 6-0-0   3/0/6/0/0 SLAVE
PCM    PCM capture 6-0-1    3/0/6/0/1 SLAVE
PCM    PCM playback 6-1-0   3/0/6/1/0 SLAVE

ALSA Queues
id Queue_Name__________ Timer_Name__________ owner status   state PPQ  Tempo BPM   Ticks Time
Error code: -19 ( No such device ) 
Location: drumstick::Timer::Timer(drumstick::TimerId&, int, QObject*) 
terminate called after throwing an instance of 'drumstick::SequencerError'
Abort (core dumped)
coggie-28-~> fg
`cat .jackdrc`
^Cjack main caught signal 2
port deleted: DJ-Console-(WE):midi/playback_1
port deleted: ICEnsemble-ICE1724:midi/playback_1
port deleted: MT4:midi/playback_1
port deleted: MT4:midi/playback_2
port deleted: MT4:midi/playback_3
port deleted: LPK25:midi/playback_1
port deleted: Midi-Through:midi/playback_1
port deleted: DJ-Console-(WE):midi/capture_1
port deleted: ICEnsemble-ICE1724:midi/capture_1
port deleted: MT4:midi/capture_1
port deleted: MT4:midi/capture_2
port deleted: MT4:midi/capture_3
port deleted: MT4:midi/capture_4
port deleted: LPK25:midi/capture_1
port deleted: MT4:midi/capture_5
port deleted: Midi-Through:midi/capture_1
Released audio card Audio6
audio_reservation_finish
coggie-29-~> 
coggie-29-~> drumstick-sysinfo
ALSA Sequencer System Info
Compiled ALSA library: 1.0.22
Runtime ALSA library: 1.0.23
Runtime ALSA drivers: 1.0.21.
Numeric ALSA compiled library: 10016
Numeric ALSA runtime library: 10017
Numeric ALSA runtime driver: 10015
Max Clients: 192
Max Ports: 256
Max Queues: 8
Max Channels: 256
Current Queues: 0
Current Clients: 7

ALSA Timers
type__ Name________________ c/s/C/D/S Freq.
system system timer         1/0/0/0/0 1000 Hz
PCM    PCM playback 0-0-0   3/0/0/0/0 SLAVE
PCM    PCM capture 0-0-1    3/0/0/0/1 SLAVE
PCM    PCM playback 0-0-2   3/0/0/0/2 SLAVE
PCM    PCM capture 0-0-3    3/0/0/0/3 SLAVE
PCM    PCM playback 0-1-0   3/0/0/1/0 SLAVE
PCM    PCM playback 0-3-0   3/0/0/3/0 SLAVE
PCM    PCM playback 1-0-0   3/0/1/0/0 SLAVE
PCM    PCM capture 1-0-1    3/0/1/0/1 SLAVE
PCM    PCM playback 4-0-0   3/0/4/0/0 SLAVE
PCM    PCM capture 4-0-1    3/0/4/0/1 SLAVE
PCM    PCM capture 5-0-1    3/0/5/0/1 SLAVE
PCM    PCM playback 6-0-0   3/0/6/0/0 SLAVE
PCM    PCM capture 6-0-1    3/0/6/0/1 SLAVE
PCM    PCM playback 6-1-0   3/0/6/1/0 SLAVE

ALSA Sequencer clients
Client0    : "System" [Kernel]
  Port0    : "Timer"
  Port1    : "Announce"
Client14   : "Midi Through" [Kernel]
  Port0    : "Midi Through Port-0" (Software, Port, MIDI Generic)
Client24   : "MT4" [Kernel]
  Port0    : "MT4 MIDI 1" (Hardware, Port, MIDI Generic)
  Port1    : "MT4 MIDI 2" (Hardware, Port, MIDI Generic)
  Port2    : "MT4 MIDI 3" (Hardware, Port, MIDI Generic)
  Port3    : "MT4 MIDI 4" (Hardware, Port, MIDI Generic)
  Port4    : "MT4 Broadcast" (Hardware, Port, MIDI Generic)
Client28   : "LPK25" [Kernel]
  Port0    : "LPK25 MIDI 1" (Hardware, Port, MIDI Generic)
Client32   : "DJ Console (WE)" [Kernel]
  Port0    : "DJ Console (WE) MIDI 1" (Hardware, Port, MIDI Generic)
Client40   : "ICEnsemble ICE1724" [Kernel]
  Port0    : "ICE1724 MIDI" (Hardware, Port, MIDI Generic)
Client128  : "drumstick-sysinfo" [User]
Comment 4 Niels Mayer 2010-05-28 15:58:41 EDT
Upstream author, Pedro Lopez-Cabanillas, claims he cannot reproduce this crash with current 0.3.1 version. States that the Fedora package is not a release, but rather a SVN snapshot as evidenced by the packages I've installed:
drumstick-examples-0.2.99-0.3.20100208svn.fc12.x86_64
drumstick-0.2.99-0.3.20100208svn.fc12.x86_64
Comment 5 Niels Mayer 2010-05-28 17:06:08 EDT
Upstream author Pedro Lopez-Cabanillas suggested doing 
'sudo modprobe snd-hrtimer'
 prior to running Jackd.

Now drumstick-sysinfo doesn't crash. Furthermore, it looks like ALSA is using the HRTimer:

gnulem-15-~/Documents> cat /proc/asound/seq/timer
Timer for queue 0 : HR timer
  Period time : 0.001000000
  Skew : 65536 / 65536

gnulem-16-~/Documents> cat /proc/asound/timers
G0: system timer : 1000.000us (10000000 ticks)
G3: HR timer : 0.001us (1000000000 ticks)
  Client sequencer queue 0 : running
P0-0-0: PCM playback 0-0-0 : SLAVE
P0-0-1: PCM capture 0-0-1 : SLAVE
P1-0-0: PCM playback 1-0-0 : SLAVE
P1-0-1: PCM capture 1-0-1 : SLAVE
P1-0-2: PCM playback 1-0-2 : SLAVE
P1-0-3: PCM capture 1-0-3 : SLAVE
P1-1-0: PCM playback 1-1-0 : SLAVE
P2-0-0: PCM playback 2-0-0 : SLAVE
P2-0-1: PCM capture 2-0-1 : SLAVE
P4-0-0: PCM playback 4-0-0 : SLAVE
  Client application 2396 : stopped
  Client application 9950 : stopped
P4-0-1: PCM capture 4-0-1 : SLAVE

gnulem-10-~/Documents> drumstick-sysinfo
ALSA Sequencer System Info
Compiled ALSA library: 1.0.22
Runtime ALSA library: 1.0.23
Runtime ALSA drivers: 1.0.21.
Numeric ALSA compiled library: 10016
Numeric ALSA runtime library: 10017
Numeric ALSA runtime driver: 10015
Max Clients: 192
Max Ports: 256
Max Queues: 8
Max Channels: 256
Current Queues: 1
Current Clients: 9

ALSA Timers
type__ Name________________ c/s/C/D/S Freq.
system system timer         1/0/0/0/0 1000 Hz
hrtimerHR timer             1/0/0/3/0 1000000000 Hz
PCM    PCM playback 0-0-0   3/0/0/0/0 SLAVE
PCM    PCM capture 0-0-1    3/0/0/0/1 SLAVE
PCM    PCM playback 1-0-0   3/0/1/0/0 SLAVE
PCM    PCM capture 1-0-1    3/0/1/0/1 SLAVE
PCM    PCM playback 1-0-2   3/0/1/0/2 SLAVE
PCM    PCM capture 1-0-3    3/0/1/0/3 SLAVE
PCM    PCM playback 1-1-0   3/0/1/1/0 SLAVE
PCM    PCM playback 2-0-0   3/0/2/0/0 SLAVE
PCM    PCM capture 2-0-1    3/0/2/0/1 SLAVE
PCM    PCM playback 4-0-0   3/0/4/0/0 SLAVE
PCM    PCM capture 4-0-1    3/0/4/0/1 SLAVE

ALSA Queues
id Queue_Name__________ Timer_Name__________ owner status   state PPQ  Tempo BPM   Ticks Time
0  Queue-0              HR timer               129 locked running  96    120 120   48534 252.786

ALSA Sequencer clients
Client   0 : "System" [Kernel]
  Port   0 : "Timer"
  Port   1 : "Announce"
    Connecting To: 128:0, 129:0
Client  14 : "Midi Through" [Kernel]
  Port   0 : "Midi Through Port-0" (Software, Port, MIDI Generic)
    Connected From: 129:0
    Connecting To: 129:0
Client  28 : "MT4" [Kernel]
  Port   0 : "MT4 MIDI 1" (Hardware, Port, MIDI Generic)
    Connected From: 129:0
    Connecting To: 129:0
  Port   1 : "MT4 MIDI 2" (Hardware, Port, MIDI Generic)
    Connected From: 129:0
    Connecting To: 129:0
  Port   2 : "MT4 MIDI 3" (Hardware, Port, MIDI Generic)
    Connected From: 129:0
    Connecting To: 129:0
  Port   3 : "MT4 MIDI 4" (Hardware, Port, MIDI Generic)
    Connected From: 129:0
  Port   4 : "MT4 Broadcast" (Hardware, Port, MIDI Generic)
    Connected From: 129:0
Client  32 : "BCD3000" [Kernel]
  Port   0 : "BCD3000 MIDI 1" (Hardware, Port, MIDI Generic)
    Connected From: 130:2, 129:0
    Connecting To: 130:0, 129:0
Client  36 : "UM-2" [Kernel]
  Port   0 : "UM-2 MIDI 1" (Hardware, Port, MIDI Generic)
    Connected From: 130:1, 129:0
    Connecting To: 129:0
  Port   1 : "UM-2 MIDI 2" (Hardware, Port, MIDI Generic)
    Connected From: 129:0
    Connecting To: 129:0
Client 128 : "Client-128" [User]
  Port   0 : "qjackctl" (Application)
    Connected From: 0:1
Client 129 : "jack_midi" [User]
  Port   0 : "port" (Application)
    Connected From: 0:1, 14:0, 28:0, 28:1, 28:2, 32:0, 36:0, 36:1, 130:1, 130:2
    Connecting To: 14:0, 28:0, 28:1, 28:2, 28:3, 28:4, 32:0, 36:0, 36:1, 130:0
Client 130 : "QMidiRoute" [User]
  Port   0 : "QMidiRoute" (Application)
    Connected From: 32:0, 129:0
  Port   1 : "QMidiRoute" (Application)
    Connecting To: 36:0, 129:0
  Port   2 : "QMidiRoute" (Application)
    Connecting To: 32:0, 129:0
Client 131 : "drumstick-sysinfo" [User]
Comment 6 Kevin Kofler 2010-05-28 17:08:39 EDT
I think this is actually a bug in JACK 2. I can upgrade the package to 0.3.1, I need to do it anyway, but I don't see any change in SVN that would fix this. What's failing is the call to snd_timer_open.
Comment 7 Kevin Kofler 2010-05-28 17:15:45 EDT
And by the way, the reason the current package is a snapshot is because that particular snapshot was needed to build kmid2-0.2.1. But KMid2 also needs updating anyway.
Comment 8 Kevin Kofler 2010-05-28 18:45:45 EDT
The crash should be fixed in drumstick-0.3.2-2.fc14 (thanks to Pedro Lopez-Cabanillas for the patch). I'll prepare an F12 update once I also have KMid 2.3.0 building. (I can't update just drumstick because it'd break kmid2's dependencies.)
Comment 9 Fedora Update System 2010-05-31 12:37:27 EDT
drumstick-0.3.1-2.fc13,kmid2-2.3.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/drumstick-0.3.1-2.fc13,kmid2-2.3.0-1.fc13
Comment 10 Fedora Update System 2010-05-31 12:38:12 EDT
drumstick-0.3.1-2.fc12,kmid2-2.3.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/drumstick-0.3.1-2.fc12,kmid2-2.3.0-1.fc12
Comment 11 Fedora Update System 2010-05-31 12:38:18 EDT
drumstick-0.3.1-2.fc11,kmid2-2.3.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/drumstick-0.3.1-2.fc11,kmid2-2.3.0-1.fc11
Comment 12 Niels Mayer 2010-05-31 13:09:12 EDT
Thank you for the fixes and updates. Quick bug fixing and updating like this is what makes Fedora rock, so thanks for the great work of both Kevin Kofler and 
Pedro Lopez-Cabanillas.

One question: will dependent package 'drumstick-examples' also be updated to 
0.3.1-2 ? This is a very useful package to install as drumstick-smfplayer
gets MIME-bound to display/play MIDI-type data in the filesystem and browser. Very convenient.
Comment 13 Kevin Kofler 2010-05-31 13:13:10 EDT
Yes, drumstick-examples is a subpackage of drumstick and as such will be updated along with drumstick. (And the fix for this bug is actually in drumstick-examples.)
Comment 14 Fedora Update System 2010-06-01 14:27:20 EDT
drumstick-0.3.1-2.fc12, kmid2-2.3.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update drumstick kmid2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/drumstick-0.3.1-2.fc12,kmid2-2.3.0-1.fc12
Comment 15 Niels Mayer 2010-06-01 15:58:30 EDT
The updates do not seem to have propagated to updates-testing yet, so I went ahead and installed the RPMs directly from http://admin.fedoraproject.org/updates/drumstick-0.3.1-2.fc12,kmid2-2.3.0-1.fc12

These updates fix the bug I reported in drumstick-sysinfo; i've also tested drumstick-smfplayer extensively and it works well.

However, in testing out kmid2, I found another bug:
https://bugs.kde.org/show_bug.cgi?id=240391
"kmid2 crashes due to lots of MIDI files in a directory, or browsing those files."
Comment 16 Niels Mayer 2010-06-01 19:39:22 EDT
And one more in kmid2 : https://bugs.kde.org/show_bug.cgi?id=240394
''crash first time running kmid, after confirming changes to "Configure Kmid"''
Comment 17 Kevin Kofler 2010-06-01 19:52:12 EDT
Do you know whether these are regressions or whether they were already there in 0.2.1?

I CCed myself on those upstream bugs in any case.
Comment 18 Niels Mayer 2010-06-01 20:58:06 EDT
I actually discovered kmid2 via http://admin.fedoraproject.org/updates/drumstick-0.3.1-2.fc12,kmid2-2.3.0-1.fc12 and that was my first install. I'm also new to using kde-desktop and all it's associated tools, which include these packages.
I'm a long-time gnome/linux/unix/Xwin user, though. Decided to give the new KDE a go after having such a good experience w/ qt-based tools, e.g. rosegarden, qtractor, qsynth, qxgedit, qjackctl and because of the KDE desktop's superior performance with linux pro-audio and video applications (i.e. with pulseaudio deinstalled and a variety of purpose-driven ALSA/jack audio devices one prefers to use: http://linuxaudio.org/mailarchive/lau/2010/5/23/169159 ... )
Comment 19 Fedora Update System 2010-06-04 14:52:29 EDT
drumstick-0.3.1-2.fc12, kmid2-2.3.0-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update drumstick kmid2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/drumstick-0.3.1-2.fc12,kmid2-2.3.0-2.fc12
Comment 20 Fedora Update System 2010-06-07 18:17:02 EDT
kmid2-2.3.0-2.fc13, drumstick-0.3.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2010-06-07 18:20:36 EDT
kmid2-2.3.0-2.fc11, drumstick-0.3.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2010-06-07 18:25:26 EDT
drumstick-0.3.1-2.fc12, kmid2-2.3.0-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.