Bug 597390 - F13 mysql compile lacks --with-partition build option
F13 mysql compile lacks --with-partition build option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 15:50 EDT by Hawk
Modified: 2013-07-02 23:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: mysql-5.1.47-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 598585 (view as bug list)
Environment:
Last Closed: 2010-06-24 12:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hawk 2010-05-28 15:50:43 EDT
Description of problem:
The mysql-5.1.46-1.fc13.x86_64 does not have the  --with-partition build option used when installed. Therefore, partitioning is no longer supported.

Version-Release number of selected component (if applicable):
5.1.46-1.fc13.x86_64

How reproducible:
Very, any time you want to make, alter, etc a table that needs partitions

Steps to Reproduce:
1. Create a table that uses partitions. Ex, add  /*!50100 PARTITION BY HASH (user_nbr) PARTITIONS 5 */; in your create table statement
2. try to access tables that use partitioning, the engine type is not understood
3.
  
Actual results:
ERROR 1289 (HY000): The 'partitioning' feature is disabled; you need MySQL built with '--with-partition' to have it working


Expected results:
SUCCESS

Additional info:
The same version of mysql compiled for the fc12 tree works fine.
Comment 1 Hawk 2010-05-28 15:53:22 EDT
sorry, this would refer to the mysql-server-5.1.46-1.fc13.x86_64 package rather than the plain mysql pacakge I assume.
Comment 2 Tom Lane 2010-05-28 16:43:06 EDT
Hmm.  That was never explicitly selected in our builds, but apparently the configure script silently turns it on if you enable ndbcluster.  Which we stopped doing in F-13 because upstream has discontinued support for ndbcluster as part of the base mysql source distribution.  So the fact that partition was there in F-12 is really an artifact rather than intentional.  How big is the use-case for it?
Comment 3 Hawk 2010-05-28 16:54:53 EDT
if you have large databases, like I do on my servers, partitioning can increase the performance of queries since it is able to break tables into multiple files across the file system and then prune to only do table scans in the files needed.

i can separate my 14+million row DB into files that have 4million rows, queries go from 13 seconds to 2.5 seconds. It is really needed for my server setup, and it is one of the cool new features of mysql 5.1
Comment 4 Tom Lane 2010-06-01 12:55:36 EDT
OK, I'll see about turning it back on.  Has to wait till the pending security releases get out of the testing pipeline, though; I don't want to reset the karma clock on them.
Comment 5 Hawk 2010-06-02 09:30:15 EDT
Thanks for the update. I will wait for some more news
Comment 6 Fedora Update System 2010-06-07 20:42:44 EDT
mysql-5.1.47-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/mysql-5.1.47-2.fc13
Comment 7 Fedora Update System 2010-06-08 15:38:32 EDT
mysql-5.1.47-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mysql'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/mysql-5.1.47-2.fc13
Comment 8 Fedora Update System 2010-06-24 12:25:10 EDT
mysql-5.1.47-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.