Bug 59744 - bug in ifup-post incorrectly sets hostname
bug in ifup-post incorrectly sets hostname
Status: CLOSED DUPLICATE of bug 58946
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-12 11:01 EST by David L. Parsley
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-12 11:01:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David L. Parsley 2002-02-12 11:01:29 EST
There's a bug in ifup-post near the bottom:

if [ ... \
    -a need hostname \
...

Which doesn't work since test doesn't eval the function; suggested fix:

if need_hostname && [ ...

This bug causes the hostname to be set even when need_hostname is 0
Comment 1 Bill Nottingham 2002-02-13 00:04:54 EST

*** This bug has been marked as a duplicate of 58946 ***

Note You need to log in before you can comment on or make changes to this bug.