Bug 597501 - Cannot Login Due to broken PAM PKCS11 module
Cannot Login Due to broken PAM PKCS11 module
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pam_pkcs11 (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Bob Relyea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-29 04:35 EDT by Ben Arnold
Modified: 2011-06-27 12:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 12:58:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snippet of /var/log/secure showing error message(s) for both root and regular (seawolf) user. (981 bytes, text/plain)
2010-05-29 04:35 EDT, Ben Arnold
no flags Details

  None (edit)
Description Ben Arnold 2010-05-29 04:35:55 EDT
Created attachment 417825 [details]
Snippet of /var/log/secure showing error message(s) for both root and regular (seawolf) user.

Description of problem:

Upon (pre)upgrading from F12 to 13, the PAM module for PKCS11 becomes broken.
The module fails and no user, not even root, can login to the system.

The following messages appear in /var/log/secure:
  PAM unable to dlopen(/lib/security/pam_pkcs11.so): /lib/security/pam_pkcs11.so: undefined symbol: get_slot_login_required
  PAM adding faulty module: /lib/security/pam_pkcs11.so
  FAILED LOGIN SESSION FROM (null) FOR root, Module is unknown

Downgrading to an older package, available from third-party repos, solved the problem.

Version-Release number of selected component (if applicable):
pam_pkcs11-0.6.2-2.fc13.i686
=> downgrade to: pam_pkcs11-0.5.3-29.i686

How reproducible:
Always, until package is replaced.

Steps to Reproduce:
1. Ensure the newer (0.6*) PAM_PKCS11 package is installed.
2. Probably, restart the system.
3. Attempt login.
  
Actual results:
Login failure. Text-mode fails before password is asked for; KDM reports critical system error.

Expected results:
Successful login.

Additional info:
rpm.pbone.net has working older package.
I installed pam_pkcs11-0.5.3-29.i686.rpm by booting in to another OS to d/l and then Fedora's single-user to install, and the problem disappeared.
Comment 1 arif 2010-09-20 11:24:39 EDT
Has this fallen by the wayside? We have no updates beyond pam_pkcs11-0.6.2-2.fc13 in F13 and this problem continues.
Comment 2 Jason Haar 2010-09-26 16:40:02 EDT
This is a "me too". I got this error, then fixed it by downgrading to a F12 build.

However, over the weekend I did a "yum update" and a new version came down and trashed the version I had - reintroducing this fault! How can you roll out a new version with a show-stopper bug like this? I can't see how this got past QA? I mean - it totally breaks the system? With this rpm in place, root cannot log in on the console - it doesn't get much worse than that?
Comment 3 Bug Zapper 2011-06-02 08:57:26 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2011-06-27 12:58:54 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.