Bug 59756 - Installer fails to notify the kernel to reread the partition tables in GUI mode when doing anything other than automatic partitioning
Summary: Installer fails to notify the kernel to reread the partition tables in GUI mo...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 60083 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-12 19:25 UTC by Danny Trinh
Modified: 2007-04-18 16:40 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 14:46:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Danny Trinh 2002-02-12 19:25:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
During installing Hampton beta 1 by using X, the installation program cannot 
continue, because it generates an error saying that it cannot initialize swap 
on device /dev/sda.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use PE1650, clear all patition on HDD or use new HDD
2.Boot RH from Hampton beta 1 CD
3.Select autopartition, or manually partition with Disk Druid
4.Continue with the process, and at the installing package Screen, it will 
generates the following messages:
An error occured trying to initialize swap on device /dev/sdc1 (swap 
partition). This problem is serious, and the install cannot continue.
	

Actual Results:  Cannot install Hampton beta 1 through X.

Expected Results:  Must be able to install by using X.

Additional info:

I don't have this problem, if I use text mode.

Comment 1 Michael Fulbright 2002-02-13 00:59:02 UTC
If you modified the partition table in anyway, you will get an error (as
mentioned in the release notes).

Have you tried an install where you just use/format existing partitions?

Comment 2 Danny Trinh 2002-02-13 14:57:36 UTC
1) Think about new comers from M$ world. What does he do if he face this 
problem after he bought a RH package?

2) When I have this problem and then restart RH install again. The process goes 
through. Is that the way new RH version will be? You must reboot at the middle 
of first installation to complete the process at the second try.


Comment 3 Michael Fulbright 2002-02-13 19:37:54 UTC
This is an issue currently as mentioned in the release notes for beta 1. There
is no intention for this to be the behavior of the final product.

Comment 4 Matt Wilson 2002-02-13 22:22:17 UTC
Fixed in CVS


Comment 5 Jeremy Katz 2002-02-19 23:07:47 UTC
*** Bug 60083 has been marked as a duplicate of this bug. ***

Comment 6 Danny Trinh 2002-02-20 14:46:48 UTC
This problem also happens when you select automatic partition, if the HDD 
doesn't have any previous partition (blank HDD).

Comment 7 Jay Turner 2002-03-07 16:20:04 UTC
Not seeing this issue with the beta2 tree (Hampton-re0304.1)


Note You need to log in before you can comment on or make changes to this bug.