Bug 5976 - /sbin/ifup cannot bring up virtual host interfaces (eth0:0)
/sbin/ifup cannot bring up virtual host interfaces (eth0:0)
Status: CLOSED DUPLICATE of bug 5784
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-15 02:27 EDT by alan
Modified: 2014-03-16 22:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-16 00:00:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alan 1999-10-15 02:27:11 EDT
[root@goliath /root]# /sbin/ifup
eth0:0
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
192.168.2.252: unknown interface: No such device
Usage: inet_route [-vF] del {-host|-net} Target[/prefix] [gw
Gw] [metric M] [[dev] If]
       inet_route [-vF] add {-host|-net} Target[/prefix] [gw
Gw] [metric M]
                              [netmask N] [mss Mss] [window
W] [irtt I]
                              [mod] [dyn] [reinstate] [[dev]
If]
       inet_route [-vF] add {-host|-net} Target[/prefix]
[metric M] reject
       inet_route [-FC] flush      NOT supported
usage: /etc/sysconfig/network-scripts/ifup-aliases
<net-device>
usage: /etc/sysconfig/network-scripts/ifup-routes
<net-device>
Comment 1 Bill Nottingham 1999-10-15 11:38:59 EDT
What does ifcfg-eth0:0 look like?
Comment 2 alan 1999-10-15 18:59:59 EDT
Here is some script output indicative of the problem.  If you scan
through it you will notice that nowhere does the DEVICE variable ever
get set.  This, in turn, causes the DEVICETYPE and REALDEVICE
variables to be null..... resulting chaos insues.


Script started on Fri Oct 15 17:56:09 1999
[root@hudson network-scripts]# set -x
[root@hudson network-scripts]# . /sbin/ifup eth0:0
+ . /sbin/ifup eth0:0
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin
++ cd /etc/sysconfig/network-scripts
++ . network-functions
++ need_hostname
+++ hostname
+++ hostname
+++ hostname
++ [ hudson.wild.prv = (none) -o hudson.wild.prv = localhost -o
hudson.wild.prv = localhost.localdomain ]
++ unset NEEDHOSTNAME
++ CONFIG=eth0:0
++ [ -z eth0:0 ]
++ [ -f eth0:0 ]
++ CONFIG=ifcfg-eth0:0
++ [ -f ifcfg-eth0:0 ]
++ [ 0 != 0 ]
++ source_config
+++ basename ifcfg-eth0:0
+++ sed s/^ifcfg-//g
++ DEVNAME=eth0:0
++ basename ifcfg-eth0:0
++ grep [^g]-
++ . ifcfg-eth0:0
+++ IPADDR=192.168.2.254
+++ NETMASK=255.255.0.0
++ [ foo = fooboot -a  = no ]
++ IPSETUP=no
+++ echo
+++ sed s/[0-9]*$//
++ DEVICETYPE=
+++ echo
+++ sed s/:.*//g
++ REALDEVICE=
++ echo
++ grep -q :
++ ISALIAS=no
++ [  = yes ]
++ [  = bootp -o  = dhcp ]
++ OTHERSCRIPT=/etc/sysconfig/network-scripts/ifup-
++ [ -x /etc/sysconfig/network-scripts/ifup- ]
++ /sbin/ifconfig
++ grep -s not found
++ [ 1 = 0 ]
++ [  = yes -a no = no -a  !=  -a -x /sbin/ifenslave ]
++ [ -n  ]
++ [ -n  ]
++ [ -z 255.255.0.0 ]
++ [ -z  ]
+++ /bin/ipcalc --broadcast 192.168.2.254 255.255.0.0
++ eval BROADCAST=192.168.255.255
+++ BROADCAST=192.168.255.255
++ [ -z  ]
+++ /bin/ipcalc --network 192.168.2.254 255.255.0.0
++ eval NETWORK=192.168.0.0
+++ NETWORK=192.168.0.0
++ ifconfig 192.168.2.254 netmask 255.255.0.0 broadcast
192.168.255.255
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
192.168.2.254: unknown interface: No such device
++ [ no = no ]
+++ route -n
+++ sed s/ .*//
+++ grep 192.168.0.0
++ [ -z 192.168.0.0 ]
++ route add -host 192.168.2.254
SIOCADDRT: No such device
++ [  !=  -a  != none ]
++ . /etc/sysconfig/network
+++ NETWORKING=yes
+++ FORWARD_IPV4=no
+++ HOSTNAME=hudson.wild.prv
+++ GATEWAY=192.168.2.51
+++ GATEWAYDEV=eth0
++ [ 192.168.2.51 !=  ]
++ [ eth0 =  -o eth0 =  ]
++ [  = yes ]
++ exec /etc/sysconfig/network-scripts/ifup-post ifcfg-eth0:0
usage: /etc/sysconfig/network-scripts/ifup-aliases <net-device>
usage: /etc/sysconfig/network-scripts/ifup-routes <net-device>

Script done on Fri Oct 15 17:56:20 1999
Comment 3 alan 1999-10-15 19:46:59 EDT
Here is some script output indicative of the problem.  If you scan
through it you will notice that nowhere does the DEVICE variable ever
get set.  This, in turn, causes the DEVICETYPE and REALDEVICE
variables to be null..... resulting chaos insues.


Script started on Fri Oct 15 17:56:09 1999
[root@hudson network-scripts]# set -x
[root@hudson network-scripts]# . /sbin/ifup eth0:0
+ . /sbin/ifup eth0:0
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin
++ cd /etc/sysconfig/network-scripts
++ . network-functions
++ need_hostname
+++ hostname
+++ hostname
+++ hostname
++ [ hudson.wild.prv = (none) -o hudson.wild.prv = localhost -o
hudson.wild.prv = localhost.localdomain ]
++ unset NEEDHOSTNAME
++ CONFIG=eth0:0
++ [ -z eth0:0 ]
++ [ -f eth0:0 ]
++ CONFIG=ifcfg-eth0:0
++ [ -f ifcfg-eth0:0 ]
++ [ 0 != 0 ]
++ source_config
+++ basename ifcfg-eth0:0
+++ sed s/^ifcfg-//g
++ DEVNAME=eth0:0
++ basename ifcfg-eth0:0
++ grep [^g]-
++ . ifcfg-eth0:0
+++ IPADDR=192.168.2.254
+++ NETMASK=255.255.0.0
++ [ foo = fooboot -a  = no ]
++ IPSETUP=no
+++ echo
+++ sed s/[0-9]*$//
++ DEVICETYPE=
+++ echo
+++ sed s/:.*//g
++ REALDEVICE=
++ echo
++ grep -q :
++ ISALIAS=no
++ [  = yes ]
++ [  = bootp -o  = dhcp ]
++ OTHERSCRIPT=/etc/sysconfig/network-scripts/ifup-
++ [ -x /etc/sysconfig/network-scripts/ifup- ]
++ /sbin/ifconfig
++ grep -s not found
++ [ 1 = 0 ]
++ [  = yes -a no = no -a  !=  -a -x /sbin/ifenslave ]
++ [ -n  ]
++ [ -n  ]
++ [ -z 255.255.0.0 ]
++ [ -z  ]
+++ /bin/ipcalc --broadcast 192.168.2.254 255.255.0.0
++ eval BROADCAST=192.168.255.255
+++ BROADCAST=192.168.255.255
++ [ -z  ]
+++ /bin/ipcalc --network 192.168.2.254 255.255.0.0
++ eval NETWORK=192.168.0.0
+++ NETWORK=192.168.0.0
++ ifconfig 192.168.2.254 netmask 255.255.0.0 broadcast
192.168.255.255
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
192.168.2.254: unknown interface: No such device
++ [ no = no ]
+++ route -n
+++ sed s/ .*//
+++ grep 192.168.0.0
++ [ -z 192.168.0.0 ]
++ route add -host 192.168.2.254
SIOCADDRT: No such device
++ [  !=  -a  != none ]
++ . /etc/sysconfig/network
+++ NETWORKING=yes
+++ FORWARD_IPV4=no
+++ HOSTNAME=hudson.wild.prv
+++ GATEWAY=192.168.2.51
+++ GATEWAYDEV=eth0
++ [ 192.168.2.51 !=  ]
++ [ eth0 =  -o eth0 =  ]
++ [  = yes ]
++ exec /etc/sysconfig/network-scripts/ifup-post ifcfg-eth0:0
usage: /etc/sysconfig/network-scripts/ifup-aliases <net-device>
usage: /etc/sysconfig/network-scripts/ifup-routes <net-device>

Script done on Fri Oct 15 17:56:20 1999
Comment 4 webguy 1999-10-15 21:57:59 EDT
Had the same problem. ifcfg-eth0:0 says:

IPADDR="10.200.7.44"
NETMASK="255.255.0.0"
Comment 5 Bill Nottingham 1999-10-16 00:00:59 EDT
Yup, it's a bug with the 6.1 initscripts. It's fixed in the latest
initscripts package in Raw Hide.

*** This bug has been marked as a duplicate of 5784 ***

Note You need to log in before you can comment on or make changes to this bug.