Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 597780 - Xorg fails to switch vt's
Xorg fails to switch vt's
Status: CLOSED DUPLICATE of bug 597778
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-30 09:36 EDT by Andy Cobaugh
Modified: 2018-04-11 04:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 18:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Cobaugh 2010-05-30 09:36:59 EDT
Description of problem:
Xorg fails to switch virtual terminals (alt+F2, for example). There are messages like these in /var/log/Xorg.0.log:

[  8450.434] Failed to switch from vt01 to vt03: Input/output error
[  8453.789] Failed to switch from vt01 to vt06: Input/output error


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.8.0-12.fc13.i686


How reproducible:
100%

Steps to Reproduce:
1. Press Alt+F2
2.
3.
  
Actual results:

Nothing happens. Messages logged to Xorg.0.log

Expected results:

Should switch to a differnt VT.


Additional info:
Comment 1 Matěj Cepl 2010-06-01 14:52:54 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue. Particularly we would need more information about why something doesn't want to switch you to the console.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Andy Cobaugh 2010-06-01 15:08:27 EDT
This bug actually seems directly related to bug 597778. Before the issue in 597778 crops up, I switch VTs just fine, but afterwards I can't.
Comment 3 Andy Cobaugh 2010-06-01 15:10:08 EDT
Only additional item is this single message in /var/log/Xorg.0.log :

[  8994.992] Failed to switch from vt01 to vt02: Input/output error

dmesg and /var/log/messages remain the same.
Comment 4 Matěj Cepl 2010-06-02 18:51:01 EDT
(In reply to comment #2)
> This bug actually seems directly related to bug 597778. Before the issue in
> 597778 crops up, I switch VTs just fine, but afterwards I can't.    

Right, so I will make this bug just another symptom of bug 597778 and close this one as a duplicate.

Complaints?

*** This bug has been marked as a duplicate of bug 597778 ***

Note You need to log in before you can comment on or make changes to this bug.