This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 597849 - Fedora 13 LXDE battery monitor always shows 100% on Asus ul50vt laptop
Fedora 13 LXDE battery monitor always shows 100% on Asus ul50vt laptop
Status: CLOSED DUPLICATE of bug 561311
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-30 14:31 EDT by Jason
Modified: 2010-06-30 11:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 11:33:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason 2010-05-30 14:31:54 EDT
Description of problem:

I recently installed Fedora 13 LXDE on my Asus laptop, and everything but the battery manager seems to be working, and I can't seem to find a way to fix it.  If it helps to note, I am new to actually maintaining my own Linux install.  The battery monitor always shows that the battery level is at 100%. 

Version-Release number of selected component (if applicable):

Fedora 13
Unsure of how to find a version number for the battery monitor

How reproducible:

Has never moved out of 100%

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:

I also attached a printout of the devkit-power --dump.  Note that at this point, the power monitor says that the battery capacity is 100%.


Device: /org/freedesktop/UPower/devices/line_power_AC0
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/ACPI0003:00/power_supply/AC0
  power supply:         yes
  updated:              Sun May 30 11:03:31 2010 (1300 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             no

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/PNP0C0A:00/power_supply/BAT0
  vendor:               ASUSTEK
  model:                UL50-58
  power supply:         yes
  updated:              Sun May 30 11:25:07 2010 (4 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    energy:              64.106 Wh
    energy-empty:        0 Wh
    energy-full:         79.114 Wh
    energy-full-design:  81.2 Wh
    energy-rate:         15.736 W
    voltage:             15.54 V
    time to empty:       4.1 hours
    percentage:          81.0299%
    capacity:            97.431%
    technology:          lithium-ion
  History (charge):
    1275243907	81.030	discharging
    1275243877	81.189	discharging
    1275243847	81.366	discharging
    1275243817	81.525	discharging
  History (rate):
    1275243907	15.736	discharging
    1275243877	16.590	discharging
    1275243847	15.330	discharging
    1275243817	16.352	discharging

Daemon:
  daemon-version:  0.9.4
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      yes
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:   yes
Comment 1 Steven M. Parrish 2010-06-04 22:23:29 EDT
Reassigning to correct component



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Jiri Skala 2010-06-07 03:17:09 EDT
Hi,
I'd like to verify I've understood your problem correctly. Does the graphical component on your panel show something like 'Laptop battery (100%)'?

Then you can get version of this component in terminal using:

$ rpm -q gnome-power-manager

Try in terminal also

$ acpi

when power supply is on and off. This should generate output:
AC on:
Battery 0: Unknown, 95%

AC off
Battery 0: Discharging, 96%, 01:49:51 remaining

Wait a second to call acpi command after switching off AC. Firstly you should get info laptop runs on battery.
Try to update gnome-power-manager (or reinstall # sudo yum reinstall gnome....).

Output of devkit-power seems to be ok.

Thanks, Jiri
Comment 3 Jason 2010-06-23 23:08:41 EDT
Alright, I've tried a couple different things.  First off, to answer your questions above:

1.) rpm -q gnome-power-manager

gnome-power-manager-2.30.1-1.fc13.x86_64

2.) acpi (on)
Battery 0: Charging, 28%, 01:39:20 until charged (at this point, gui shows 
Battery: 100% charged, 0:-28 until full)

    acpi (off)
Battery 0: Discharging, 29%, 01:17:42 remaining (at this point, gui shows 
Battery: 100% charged)

Also, I did attempt to reinstall, but there was no luck.

From what I was seeing, and the pattern you can see above, it appears possible the percentages and time remaining may be reversed.  See the results when acpi is on.  This is just a theory, I don't have the code to tell what is occurring, but thought maybe I'd throw that theory out there.  

Thanks!
Comment 4 Jiri Skala 2010-06-25 08:17:13 EDT
Thanks for your tests. This is strange. You have exact the same g-p-m as mine. I've heard about earlies issue in upower but your output seems to be correct.

Well, let's ask g-p-m & upower maintainer. Richard do you have an idea what's wrong?
Comment 5 Jason 2010-06-25 08:47:12 EDT
Also, I should note that when I completely exhausted the battery, then plugged it in and started recharging it, the battery manager only took a few seconds to show 100% charged, although according to the terminal printout there was approximately 2.5 hours until the battery was 100%.  So, in short, it's not that it always shows 100% as it turns out.  When the battery level got extremely low (~20%), the battery manager began updating the GUI display.  Then, when charging from dead, the battery manager started showing no bar on the GUI (no charge) and quickly drew the bar up to 100%.  Thought I'd share this if it further details the problem any further to help diagnose the issue.  Also, a friend mentioned that it could be a problem with the bios reporting, but I'd assume that if that was the case, the acpi would also have incorrect information, correct?

Thanks!
Comment 6 Jiri Skala 2010-06-25 09:00:55 EDT
I suppose this could be a duplicity to

https://bugzilla.redhat.com/show_bug.cgi?id=499948

This is filed against F-11 but comment #60 complains F-13 too.

Jiri
Comment 7 Richard Hughes 2010-06-28 04:47:00 EDT
(In reply to comment #0)
> Device: /org/freedesktop/UPower/devices/battery_BAT0
>   native-path:         
> /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/PNP0C0A:00/power_supply/BAT0
>   vendor:               ASUSTEK
>   model:                UL50-58
>   power supply:         yes
>   updated:              Sun May 30 11:25:07 2010 (4 seconds ago)
>   has history:          yes
>   has statistics:       yes
>   battery
>     present:             yes
>     rechargeable:        yes
>     state:               discharging
>     energy:              64.106 Wh
>     energy-empty:        0 Wh
>     energy-full:         79.114 Wh
>     energy-full-design:  81.2 Wh
>     energy-rate:         15.736 W
>     voltage:             15.54 V
>     time to empty:       4.1 hours
>     percentage:          81.0299%
>     capacity:            97.431%
>     technology:          lithium-ion

That all looks very sensible. Are you sure you are using g-p-m, or has LXDE got it's own power manager program?
Comment 8 Jason 2010-06-29 21:26:40 EDT
Not sure, how would I check?
Comment 9 Christoph Wickert 2010-06-30 10:16:38 EDT
I guess Jason is using the battery plugin of LXPanel, is this correct?
Comment 10 Jason 2010-06-30 11:00:36 EDT
I am using whatever comes with the Fedora 13 LXDE.  I do not know of a command to check, but if someone could tell me what to look for on the computer, I can get you the info. you need.  Thanks!
Comment 11 Christoph Wickert 2010-06-30 11:19:26 EDT
How did you add the battery monitor to the panel? Via 

  Panel Settings -> Panel Plugins -> Add -> Battery Monitor?

What does it look like? Is there an icon or is it just a green bar?

If so, what you are seeing is a duplicate of bug 561311.
Comment 12 Jason 2010-06-30 11:25:37 EDT
It was Right Click (on toolbar) -> Panel Settings -> Add -> Battery Monitor.  This is probably the same as you were saying.  There is just a green bar that, when hovered over, shows the remaining time and battery percentage.  Is there another battery monitor that I could try out and add into the panel?

I will check out the bug you linked to.

Thank you.
Comment 13 Christoph Wickert 2010-06-30 11:33:11 EDT
OK, lets gather all of this in bug 561311.

*** This bug has been marked as a duplicate of bug 561311 ***

Note You need to log in before you can comment on or make changes to this bug.