Bug 59785 - RFE: Does not recognise NFS permisson problem
RFE: Does not recognise NFS permisson problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 04:15 EST by Emmanuel Galanos
Modified: 2007-03-26 23:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 18:48:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Galanos 2002-02-13 04:15:24 EST
Description of Problem:
Attempting to do an install via NFS, I had made a mistake with the directory
permissions on the server such that the directory could be mounted fine, but
that the directory was not searchable. Anaconda gave a message about not being
able to find the install tree. Ideally it should have given an error about
not being able to read the directory.

Version-Release number of selected component (if applicable):
7.2.90 beta 1

How Reproducible:
100 %

Steps to Reproduce:
1. Create mount point with world executable but not readable
2. Attempt to use for anaconda

Actual Results:
Error message about not being able to find Red Hat install tree.

Expected Results:
Permission denied by server error message.

Additional Information:
NFS server running RH 7.1
Comment 1 Jeremy Katz 2002-04-08 19:38:51 EDT
We're in a string freeze, so can't really add new dialogs at this point.
Comment 2 Jeremy Katz 2003-07-28 18:48:54 EDT
This looks like it should be fixed in our current code

Note You need to log in before you can comment on or make changes to this bug.