Bug 597879 - SELinux is preventing /var/lib/boinc/slots/3/freeze "read" access on tcp.
SELinux is preventing /var/lib/boinc/slots/3/freeze "read" access on tcp.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:64ac458e945...
:
: 597880 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-30 17:30 EDT by Daniel Stripes
Modified: 2010-06-08 15:28 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-23.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 15:28:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Stripes 2010-05-30 17:30:53 EDT
Summary:

SELinux is preventing /var/lib/boinc/slots/3/freeze "read" access on tcp.

Detailed Description:

[freeze has a permissive type (boinc_t). This access was not denied.]

SELinux denied access requested by freeze. It is not expected that this access
is required by freeze and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:boinc_t:s0
Target Context                system_u:object_r:proc_net_t:s0
Target Objects                tcp [ file ]
Source                        freeze
Source Path                   /var/lib/boinc/slots/3/freeze
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-21.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.4-95.fc13.i686.PAE #1
                              SMP Thu May 13 05:38:26 UTC 2010 i686 i686
Alert Count                   20
First Seen                    Sat 29 May 2010 10:43:39 PM EDT
Last Seen                     Sun 30 May 2010 05:20:05 PM EDT
Local ID                      6ee6fc38-cd94-4485-b5bb-07ffd190eb89
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1275254405.182:46): avc:  denied  { read } for  pid=3364 comm="freeze" name="tcp" dev=proc ino=4026531955 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1275254405.182:46): avc:  denied  { open } for  pid=3364 comm="freeze" name="tcp" dev=proc ino=4026531955 scontext=system_u:system_r:boinc_t:s0 tcontext=system_u:object_r:proc_net_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1275254405.182:46): arch=40000003 syscall=5 per=400000 success=yes exit=8 a0=804c5e2 a1=0 a2=1b6 a3=804c477 items=0 ppid=3303 pid=3364 auid=4294967295 uid=492 gid=486 euid=492 suid=492 fsuid=492 egid=486 sgid=486 fsgid=486 tty=(none) ses=4294967295 comm="freeze" exe="/var/lib/boinc/slots/3/freeze" subj=system_u:system_r:boinc_t:s0 key=(null)



Hash String generated from  catchall,freeze,boinc_t,proc_net_t,file,read
audit2allow suggests:

#============= boinc_t ==============
allow boinc_t proc_net_t:file { read open };
Comment 1 Miroslav Grepl 2010-05-31 06:06:36 EDT
*** Bug 597880 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2010-06-01 07:56:55 EDT
Fixed in selinux-policy-3.7.19-23.fc13
Comment 3 Fedora Update System 2010-06-02 05:04:26 EDT
selinux-policy-3.7.19-23.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-23.fc13
Comment 4 Fedora Update System 2010-06-02 14:12:44 EDT
selinux-policy-3.7.19-23.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.7.19-23.fc13
Comment 5 Fedora Update System 2010-06-08 15:26:59 EDT
selinux-policy-3.7.19-23.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.