Bug 597910 - [abrt] crash in system-config-printer-1.2.1-1.fc13: _dl_fini: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in system-config-printer-1.2.1-1.fc13: _dl_fini: Process /usr/bi...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:629aca489b9fb4a38417d34af73...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 00:22 UTC by jan p. springer
Modified: 2010-07-01 18:38 UTC (History)
4 users (show)

Fixed In Version: system-config-printer-1.2.3-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 18:38:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (29.38 KB, text/plain)
2010-05-31 00:22 UTC, jan p. springer
no flags Details

Description jan p. springer 2010-05-31 00:22:49 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
crash_function: _dl_fini
executable: /usr/bin/python
global_uuid: 629aca489b9fb4a38417d34af73280fdb168f1d1
kernel: 2.6.33.4-95.fc13.x86_64
package: system-config-printer-1.2.1-1.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Comment 1 jan p. springer 2010-05-31 00:22:50 UTC
Created attachment 418132 [details]
File: backtrace

Comment 2 Jiri Popelka 2010-05-31 08:07:55 UTC
Jan,
are you able to reproduce it or did this happen only once ?


Looking at the backtrace,
it looks like the problem occurred in glibc (dl-fini.c).

Reassigning component from "system-config-printer" to "glibc";
hopefully the glibc maintainer will be able to figure this out
further or reassign as necessary.

Comment 3 Andreas Schwab 2010-05-31 10:21:03 UTC
There is some memory corruption, the DT_FINI address is bogus.

Comment 4 Tim Waugh 2010-06-25 15:18:30 UTC
Could be caused by bug #584991 perhaps.

Comment 5 Fedora Update System 2010-06-28 16:32:01 UTC
system-config-printer-1.2.3-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-printer-1.2.3-3.fc13

Comment 6 Fedora Update System 2010-06-28 23:37:38 UTC
system-config-printer-1.2.3-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-printer-1.2.3-3.fc13

Comment 7 Fedora Update System 2010-07-01 18:37:44 UTC
system-config-printer-1.2.3-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.