Bug 59802 - Crontab(5) manpage incorrect time specification logic
Crontab(5) manpage incorrect time specification logic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 10:18 EST by Enrique Perez-Terron
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version: vixie-cron-4.1-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 15:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrique Perez-Terron 2002-02-13 10:18:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; YIE6)

Description of problem:
One stray word changes the meaning of the statement.
"Commands are executed by cron(8) when the minute,
hour, and month of year fields match the current time, and when at least one of 
the two day fields (day of month, or day of week) match the current time"

The second "when" makes the statement say that the command is executed at two 
kinds of occasions, when the minute, hour and month specifications math the 
current time, and also at any time when one of the two day specifications 
match. What is meant is that the command is executed when four out of the five 
fields match, and the one that does not match (if any) is one of the day fields.

The logical structure as it stands is like "execution happens when condition A, 
and also when condition B is met". What is meant is that execution happens when 
conditions A and B are both met simultaneously.

Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-63


How reproducible:
Always

Steps to Reproduce:
1. man 5 crontab.
2. /minute<enter>
3. /when<enter>
(i.e. use the '/' key to do text search in the output of 'man'.)

Additional info:
Comment 1 Jens Petersen 2004-06-30 13:47:43 EDT
Would it be sufficient to remove the second "when"?

cron.8 will change significantly when we upgrade to cron 4.1 btw.
Comment 2 Jens Petersen 2004-06-30 13:49:46 EDT
Err, actually the above sentence no longer appears in cron.8.
Comment 3 Enrique Perez-Terron 2004-07-06 05:44:43 EDT
It is not in cron.8, it is in cron.5
Comment 4 Enrique Perez-Terron 2004-07-06 06:02:40 EDT
Of course removing the second 'when' will restore the intended meaning.
Comment 5 Jason Vas Dias 2004-08-10 15:32:23 EDT
Second "when" now removed from crontab.5 in vixie-cron-4.1-8 .

Note You need to log in before you can comment on or make changes to this bug.