Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598022 - Hot-added device is not visible in guest after live-migration.
Hot-added device is not visible in guest after live-migration.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Alex Williamson
Virtualization Bugs
: Reopened
: 580457 (view as bug list)
Depends On: 507191
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 05:27 EDT by Dor Laor
Modified: 2013-01-09 17:39 EST (History)
17 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.78.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 507191
Environment:
Last Closed: 2010-11-10 16:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 RHEL Product and Program Management 2010-05-31 05:35:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Alex Williamson 2010-06-07 11:14:54 EDT
patch posted upstream - http://lists.nongnu.org/archive/html/qemu-devel/2010-06/msg00301.html
Comment 3 Gerd Hoffmann 2010-06-08 10:58:29 EDT
*** Bug 580457 has been marked as a duplicate of this bug. ***
Comment 7 Cao, Chen 2010-07-05 22:59:59 EDT
reproduced on qemu-kvm-0.12.1.2-2.77

verified on qemu-kvm-0.12.1.2-2.78 and qemu-kvm-0.12.1.2-2.90


source vm command:
qemu -name vm1 -monitor stdio -drive file=./RHEL-Server-6.0-64.qcow2,if=ide,cache=none,aio=native  -m 2048 -smp 1 -vnc :1  -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2 -no-kvm-pit-reinjection  -snapshot


dest vm command:
qemu -name vm1 -monitor stdio -drive file=./RHEL-Server-6.0-64.qcow2,if=ide,cache=none,aio=native  -m 2048 -smp 1 -vnc :1  -usbdevice tablet -rtc-td-hack -cpu qemu64,+sse2 -no-kvm-pit-reinjection  -snapshot  -incoming tcp:localhost:4444


migrate command:
migrate tcp:localhost:4444


device add command:
netdev_add tap,id=foo
device_add rtl8139,mac=02:6F:F6:3D:b9:b2,id=foo_1,netdev=foo
Comment 8 releng-rhel@redhat.com 2010-11-10 16:25:24 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.