Bug 59803 - [RFE] Escape spaces in mount points
Summary: [RFE] Escape spaces in mount points
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-13 15:22 UTC by Emmanuel Galanos
Modified: 2007-03-27 03:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 02:36:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Emmanuel Galanos 2002-02-13 15:22:00 UTC
Description of Problem:
Using a space in the mount point in Disk druid produces an entry in the
/etc/fstab with a space rather than escaping with a \040 . This obviously
causes the entry to not work.

Version-Release number of selected component (if applicable):
7.2.90 beta1

How Reproducible:
100%

Steps to Reproduce:
1. Try and create mount point for partition in Disk druid with space (eg
"/Windows 98"

Actual Results:
Breakage.

Expected Results:
Bliss and happiness.

Comment 1 Michael Fulbright 2002-02-13 19:23:50 UTC
Thanks for catching this, we had intended to not allow spaces in mount points in
the first place and it slipped through our mount point sanity checking routine.

Comment 2 Emmanuel Galanos 2002-02-13 22:54:03 UTC
I would request that you do not block this, but just use the escape
sequence in /etc/fstab . No need to unnecessarily limit someone.

Comment 3 Jay Turner 2002-03-07 16:25:33 UTC
Changing this to be an enhancement request.  With the current code, we are
preventing the use of spaces in the mount point label.

Comment 4 Jeremy Katz 2002-04-09 00:52:46 UTC
Too late for this release, will revisit for a future release


Note You need to log in before you can comment on or make changes to this bug.