Bug 598236 - OpenOffice 3.2.0 using KDE - No native open/save file dialog - no option to select otherwise
OpenOffice 3.2.0 using KDE - No native open/save file dialog - no option to s...
Status: CLOSED DUPLICATE of bug 171908
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 17:05 EDT by mrh
Modified: 2010-05-31 18:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-31 17:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mrh 2010-05-31 17:05:56 EDT
OpenOffice 3.2.0 build 9483, Fedora 13 using KDE


Steps to Reproduce:
1. Open or save a file ==> old style dialog 
2. Tools->Options->OpenOffice.org->General ==> no option to change dialog
  
Actual results:

On fresh installation of openoffice, open file dialog is old style, OO native dialog (very ugly)

Tools->Options->OpenOffice.org->General does not provide any option to deselect "Use OpenOffice.org dialogs"

Expected results:

Fresh install would naturally disable the OO dialogs and use native file dialog
Tools->Options->OpenOffice.org->General does not show option to disable

Function would behave and display as described in documentation OpenOffice.org3 - Getting Started Guide - page 6 "Open/Save dialogs"

and in Chapter 1, page 24

<quote>
You can choose whether to use the OpenOffice.org Open and Save As
dialogs or the ones provided by your operating system.
To view or change which type of dialog OpenOffice.org uses:
1) Choose Tools > Options > OpenOffice.org > General.
2) Select the Use OpenOffice.org dialogs option.
</quote>

Additional info:

I also have to set the env variable OOO_FORCE_DESKTOP="kde" to get the icons to display properly (as in OO on Kubuntu 10.04)

Same result for installs from OpenOffice.org download or from fedora 13 repository using yum.

I have the same build running on my laptop using Kubuntu 10.04. It behaves correctly there.
Comment 1 Caolan McNamara 2010-05-31 17:38:00 EDT
We don't currently build the KDE integration stuff

*** This bug has been marked as a duplicate of bug 171908 ***
Comment 2 mrh 2010-05-31 18:35:02 EDT
(In reply to comment #1)
> We don't currently build the KDE integration stuff
> 
> *** This bug has been marked as a duplicate of bug 171908 ***    

I am confused. The duplicate has been open since 2005. There's been no activity on it since 2008, with promises at that time for a resolution. We've had tremendous advances since. As it is, it just makes Fedora "old". So the question now is, "Given that other distributions support it just fine, why not Fedora?"

Note You need to log in before you can comment on or make changes to this bug.