Bug 59830 - importing addresses from pine
Summary: importing addresses from pine
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-13 18:54 UTC by Tim Waugh
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 21:31:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Try this entry. (86 bytes, text/plain)
2002-02-15 11:27 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2002-02-13 18:54:15 UTC
Description of Problem:
The import agent for getting addresses from a Pine address book sometimes
creates entries like:

Full name: First Last
Primary Email: "first last" <first.last@domain.com>

When sending email to that contact, it is formed like this:

First Last <"First Last" <first.last@domain.com> >

which obviously isn't what we want. :-)

The 'primary email' field should just be first.last@domain.com in this instance.

Version-Release number of selected component (if applicable):
1.0.2-1

Comment 1 Jeremy Katz 2002-02-13 19:26:53 UTC
If this only happens sometimes, do you have some pine addressbook entries that
exhibit it so I can beat on it a little?

Comment 2 Tim Waugh 2002-02-15 11:27:43 UTC
Created attachment 45785 [details]
Try this entry.

Comment 3 Jeremy Katz 2003-07-28 22:53:10 UTC
Is this better in newer versions?

Comment 4 Tim Waugh 2003-07-29 08:00:28 UTC
I'm afraid I have no idea.

Comment 5 Dave Malcolm 2004-09-20 23:10:05 UTC
Sorry this bug has gone for so long without activity.

Relevant code appears to be in
evolution/mail/importers/pine-importer.c; it loads the file ~/.addressbook

I had a go at stepping through the import in the evolution-2.0.0 code;
currently it entirely fails to parse your attachment, leading to no
contacts being created.

Do you have any more test data I can run on this?  Do you still care
about this bug?


Comment 6 Tim Waugh 2004-09-23 10:51:15 UTC
Sorry, no to both questions.

Comment 7 Dave Malcolm 2004-09-23 21:31:53 UTC
Resolving as DEFERRED since I've got plenty of higher-priority bugs to
work on :-(


Note You need to log in before you can comment on or make changes to this bug.