Bug 598318 - [abrt] crash in gnomint-1.1.0-2.fc13: __strcmp_ssse3: Process /usr/bin/gnomint was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in gnomint-1.1.0-2.fc13: __strcmp_ssse3: Process /usr/bin/gnomin...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnomint (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Adam Huffman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0826fb023230a5fcb7d9127958f...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 05:06 UTC by Daniel VanStone
Modified: 2010-09-15 05:48 UTC (History)
2 users (show)

Fixed In Version: gnomint-1.2.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 05:48:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (72.35 KB, text/plain)
2010-06-01 05:06 UTC, Daniel VanStone
no flags Details

Description Daniel VanStone 2010-06-01 05:06:00 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gnomint
comment: gnomint would not import private CA key file
component: gnomint
crash_function: __strcmp_ssse3
executable: /usr/bin/gnomint
global_uuid: 0826fb023230a5fcb7d9127958fcdd946c16a2ee
kernel: 2.6.33.4-95.fc13.x86_64
package: gnomint-1.1.0-2.fc13
rating: 4
reason: Process /usr/bin/gnomint was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1.open gnomint
2.add CA public file
3.attempt to import private CA key 

Gnomint crashes

Comment 1 Daniel VanStone 2010-06-01 05:06:01 UTC
Created attachment 418462 [details]
File: backtrace

Comment 2 Daniel VanStone 2010-06-01 05:07:03 UTC
Package: gnomint-1.1.0-2.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.open gnomint
2.add CA public file
3.attempt to import private CA key 

Gnomint crashes


Comment
-----
gnomint would not import private CA key file

Comment 3 Adam Huffman 2010-06-06 15:20:53 UTC
Thanks for the report.  I'll pass this on to the upstream maintainer.

Comment 4 David Marin Carreño 2010-08-10 17:32:05 UTC
Cannot reproduce in just released 1.2.0 version. Please, whenever this version is available in Fedora, check if the bug remains there.

If is reproducible, I would need more info. Perhaps the bug depends on the file that is being imported...

Comment 5 Daniel VanStone 2010-08-25 12:24:52 UTC
I believe that it is tinyca files not working in or with gnomint I have stopped using it but I will try it again and see if the issue still exists. 
If I don't report back anything within 3 days I would assume that this is fixed.

Comment 6 Adam Huffman 2010-08-25 12:42:35 UTC
Daniel,

Thanks for the comment.  I'll build a new RPM for the 1.2.1 release, which will be a better basis for testing.

Comment 7 Fedora Update System 2010-08-27 11:21:18 UTC
gnomint-1.2.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnomint-1.2.1-1.fc13

Comment 8 Fedora Update System 2010-08-30 18:24:55 UTC
gnomint-1.2.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnomint'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnomint-1.2.1-1.fc13

Comment 9 Fedora Update System 2010-09-15 05:48:09 UTC
gnomint-1.2.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.