Bug 598346 - Manual page incorrectly claims the default NFS protocol version is 2/3
Manual page incorrectly claims the default NFS protocol version is 2/3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 02:49 EDT by Tore Anderson
Modified: 2010-10-27 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.2-6.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-27 18:32:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tore Anderson 2010-06-01 02:49:45 EDT
Description of problem:

From nfs(5):

>       The fstype field contains either "nfs" (for version 2 or version 3  NFS
>       mounts)  or  "nfs4"  (for NFS version 4 mounts).  The nfs and nfs4 file
>       system types share similar mount options, which are described below.

However, this appears to be incorrect since F13.  According to <http://docs.fedoraproject.org/en-US/Fedora/13/html/Release_Notes/sect-Release_Notes-File_Systems.html>:

> 5.9.2.1. NFSv4 Default
> Changes the default NFS protocol to version 4. NFSv4 will check to see if the
> server supports version 4. If the server does then it will connect. Otherwise
> it will connect using version 3.

From what I can tell, the release notes are right about this.

Version-Release number of selected component (if applicable):

F13, nfs-utils-1.2.2-2.fc13.x86_64
Comment 1 Fedora Update System 2010-10-15 18:51:25 EDT
nfs-utils-1.2.2-6.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/nfs-utils-1.2.2-6.fc13
Comment 2 Fedora Update System 2010-10-17 00:50:03 EDT
nfs-utils-1.2.2-6.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nfs-utils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/nfs-utils-1.2.2-6.fc13
Comment 3 Fedora Update System 2010-10-27 18:32:10 EDT
nfs-utils-1.2.2-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.