Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598399 - keepalived-1.2.2 is available
keepalived-1.2.2 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: keepalived (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 06:12 EDT by Upstream Release Monitoring
Modified: 2012-08-20 14:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 14:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2010-06-01 06:12:28 EDT
Latest upstream release: 1.2.0
Current version in Fedora Rawhide: 1.1.20
URL: http://www.keepalived.org/software/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 Account closed by user 2010-11-27 10:09:30 EST
2010-05-31
	Release 1.2.0 | VRRP IPv6 Release
  	
* Branch 1.2.0 created. This branch will host all new
  developments on Keepalived. New code will be added
  in here only.
* VRRP : Add support to IPv6 protocol. The global framework
  has been extended to support this branch new family !
* VRRP : Implement IPv6 Neighbour Discovery protocol (NDISC).
  In IPv6 gratuitous ARP doesnt exist since ARP is IPv4 only.
  NDISC can provide the same feature by sending so called
  Unsolicited Neighbour Advertisement. A node can send such a
  protocol datagram in order to (unreliable) propagate new
  information quickly (rfc4861.4.4). NDISC build an ICMPv6
  message with taget link-layer address option, this option is
  set icmp6_override flag to indicate that advertisement should
  override an existing cache entry and update the cached
  link-layer.
* VRRP : Extend ip address framework to be IPv4 and IPv6
  independant. An ip address, as defined in framework, is
  now {IPv4,broadcast} or {IPv6}. Use struct ifaddrmsg to
  store and prepare netlink related operation. This clean-
  -up the code.
* VRRP : Extend parser to support IPv6 declarations. IPv6
  and IPv4 addresses can be configured inside the same
  configuration block (eg: virtual_ipaddress or
  virtual_ipaddress_excluded). An instance can run IPv4 and
  IPv6 addresses at a time, this can be useful in dual-stack
  env (since this will become certainly the most common use
  case in the next years).
* VRRP : Extend netlink framwork to support IPv6 addresses
  interactions (reflection/addition/deletion).
* VRRP : Extend finite state machine support IPv4 & IPv6
  at a time.
* VRRP : Extend protocol helpers to support IPv6 multicast
  related. AF_INET6 SOCK_RAW tweaking it done through
  socket API instead of PF_PACKET header building... This
  makes code cleaner.
* VRRP : Set default VRRP instance protocol to be IPv4.
  you can use configuration keyword "native_ipv6" inside
  vrrp_instance configuration block to specify that you
  want to use IPv6 for VRRP multicasting protocol instead.
* VRRP : Extend socket option related helpers to support
  IPv6 specifics.
* VRRP : Extend protocol scheduler and dispatcher to
  support IPv6.
* VRRP : Extend socket pool to keep track of socket
  family.
* VRRP : Cleanup protocol offset pointer by removing
  duplication code...
* VRRP : some code clean-up...
Comment 2 Upstream Release Monitoring 2010-12-08 14:31:35 EST
Latest upstream release: 1.2.1
Current version in Fedora Rawhide: 1.1.20
URL: http://www.keepalived.org/software/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Upstream Release Monitoring 2011-01-17 16:37:38 EST
Latest upstream release: 1.2.2
Current version in Fedora Rawhide: 1.1.20
URL: http://www.keepalived.org/software/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 4 Account closed by user 2011-01-20 17:59:54 EST
Release 1.2.2 is IPv6 Ready: http://www.keepalived.org/changelog.html
Comment 5 Account closed by user 2011-03-26 13:58:22 EDT
ping!
Comment 6 Account closed by user 2011-05-21 15:44:49 EDT
nobody cares, closing...
Comment 7 Matthias Saou 2011-07-12 14:31:56 EDT
I do care :-)

The current 1.2.2 doesn't build on EL5 :
http://sourceforge.net/mailarchive/forum.php?thread_name=AANLkTikcY5e%3DoLMi8Q8%3DFjJRrmnv%2BoKxi9OA_pToiT%3Dz%40mail.gmail.com&forum_name=keepalived-devel

The current 1.2.2 doesn't build on Rawhide either (kernel 3.0-0.rc7.git0.1.fc16) :
http://koji.fedoraproject.org/koji/getfile?taskID=3194325&name=build.log

Also from what I've understood, rebuilding with libnl enabled is required to get the IPv6 support, but the EL5 libnl version is too old. So the enhancements are a no-go on EL5, which is the distro most people must be running on their servers.

Quite a mess, if you ask me :-/

Still, a build of 1.2.2 for F15 is on its way, though others will follow since I'd like to include a systemd service file as well as try to address the insecure pid file mode issue reported in bug #704040. I'll also check if I can push an update for EL6.
Comment 8 Fedora Update System 2011-07-13 05:50:01 EDT
keepalived-1.2.2-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/keepalived-1.2.2-2.el6
Comment 9 Fedora Update System 2011-07-30 06:35:39 EDT
keepalived-1.2.2-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Ryan O'Hara 2012-08-20 14:04:56 EDT
Not sure why this bug is sitting in MODIFIED state. I'm closing this since keepalived is up to version 1.2.6 now and updates have been pushed for epel6, fedora, and rawhide.

Note You need to log in before you can comment on or make changes to this bug.