Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598401 - latest sane update breaks gnome-color-manager compile
latest sane update breaks gnome-color-manager compile
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 06:17 EDT by Richard Hughes
Modified: 2010-06-14 13:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: sane-backends-1.0.21-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 13:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hughes 2010-06-01 06:17:59 EDT
Description of problem:

The latest sane update breaks gnome-color-manager compile by adding -I../_inst/include to the cflags. This is probably because it's expanded out from the sane-backends.pc file which contains:

Cflags: -I$(includedir)

which is expanded by automake as the destination includedir, not the sane includedir. I think it needs to be "-I${includedir}" rather than "-I$(includedir)" for this to work.

Version-Release number of selected component (if applicable):

sane-backends-1.0.21-1.fc13.i686

How reproducible:

Always.

Steps to Reproduce:
1. Try to compile g-c-m (and do make distcheck) with SANE support
2. Watch compile blow up with cc1: error: /home/hughsie/Code/gnome-color-manager/gnome-color-manager-2.31.2/_inst/include: No such file or directory

Additional info:

This works for me:

Libs: -L${libdir} -lsane
Libs.private: ${ldflags} ${libs}
Cflags: -I${includedir}
Comment 1 Richard Hughes 2010-06-02 08:03:46 EDT
Build failure in koji: http://koji.fedoraproject.org/koji/getfile?taskID=2224914&name=build.log
Comment 2 Fedora Update System 2010-06-02 08:41:34 EDT
sane-backends-1.0.21-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/sane-backends-1.0.21-2.fc13
Comment 3 Fedora Update System 2010-06-02 08:42:20 EDT
sane-backends-1.0.21-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sane-backends-1.0.21-2.fc12
Comment 4 Fedora Update System 2010-06-03 14:15:01 EDT
sane-backends-1.0.21-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sane-backends'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/sane-backends-1.0.21-2.fc13
Comment 5 Fedora Update System 2010-06-14 13:28:56 EDT
sane-backends-1.0.21-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2010-06-14 13:29:23 EDT
sane-backends-1.0.21-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.