Bug 598418 - MC stores passwords plaintext on file rather than in gnome-keyring
Summary: MC stores passwords plaintext on file rather than in gnome-keyring
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-mission-control   
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 11:32 UTC by Roman Kagan
Modified: 2010-06-21 21:40 UTC (History)
3 users (show)

Fixed In Version: telepathy-mission-control-5.4.2-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 21:26:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roman Kagan 2010-06-01 11:32:24 UTC
Description of problem:

account passwords are found in plain text together with the rest of account information in ~/.mission-control/accounts/accounts.cfg

Version-Release number of selected component (if applicable):
telepathy-mission-control-5.4.0-1.fc13

How reproducible:
100%

Steps to Reproduce:
1. add an account in empathy
2. enter account's password
3. find param-password fields with plaintext passwords
  
Actual results:
passwords are stored plaintext on file

Expected results:
passwords are stored in gnome-keyring

Additional info:
AFAICS from http://kojipkgs.fedoraproject.org/packages/telepathy-mission-control/5.4.0/1.fc13/data/logs/x86_64/build.log, gnome-keyring isn't detected by configure during build.

This in turn is due to gnome-keyring-devel missing from BuildRequires. It used to be there but disappeared between CVS revisions 1.23 and 1.24.  I can't tell the reason from the CVS logs.

Comment 1 Peter Robinson 2010-06-01 12:48:01 UTC
Will review and push out an update to fix this.

Comment 2 Peter Robinson 2010-06-01 23:42:39 UTC
Fixed in rawhide.

I'm not sure the impact of this on existing accounts so not sure about pushing it to stable releases. Do you lose the accounts when its enabled, or do they get moved over?

Comment 3 Roman Kagan 2010-06-02 09:18:41 UTC
Accounts are converted automatically.

[ This happens when /org/freedesktop/Telepathy/AccountManager is re-instantiated in dbus, i.e. when you restart a GNOME session ]

IMO it's safe to push to stable.

Comment 4 Peter Robinson 2010-06-02 10:36:45 UTC
There's a test build here http://koji.fedoraproject.org/koji/taskinfo?taskID=2224602

Comment 5 Roman Kagan 2010-06-02 10:55:12 UTC
When writing comment 2 I actually experimented with http://koji.fedoraproject.org/koji/buildinfo?buildID=176154 (yes it did install fine on my F13 box).  So consider submitting to bodhi, for others to test.

Dunno if F12 needs this too.

Comment 6 Roman Kagan 2010-06-04 13:14:57 UTC
Peter is there anything holding you from pushing this to bodhi/testing?

Comment 7 Fedora Update System 2010-06-08 21:59:27 UTC
telepathy-mission-control-5.4.2-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/telepathy-mission-control-5.4.2-3.fc12

Comment 8 Fedora Update System 2010-06-08 21:59:32 UTC
telepathy-mission-control-5.4.2-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/telepathy-mission-control-5.4.2-2.fc13

Comment 9 Fedora Update System 2010-06-10 19:12:35 UTC
telepathy-mission-control-5.4.2-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update telepathy-mission-control'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/telepathy-mission-control-5.4.2-3.fc12

Comment 10 Fedora Update System 2010-06-10 19:13:43 UTC
telepathy-mission-control-5.4.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update telepathy-mission-control'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/telepathy-mission-control-5.4.2-2.fc13

Comment 11 Fedora Update System 2010-06-21 21:26:42 UTC
telepathy-mission-control-5.4.2-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-06-21 21:40:15 UTC
telepathy-mission-control-5.4.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.