Bug 59843 - RFE: up2date should support command line channel restrioctions
RFE: up2date should support command line channel restrioctions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 15:24 EST by Chip Turner
Modified: 2015-01-07 18:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-13 17:21:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chip Turner 2002-02-13 15:24:49 EST
up2date client should support a flag that lets you restrict -u to a given set of
channel(s):

[root@minbar rhn]# up2date --show-channels
redhat-linux-i386-7.2
skunkworks-i386-7.2
rhn-satellite-i386-7.2
[root@minbar rhn]# up2date -u -c skunkworks-i386-7.2 -c rhn-satellite-i386-7.2

This would only pull from skunkworks and satellite, and not the base (so it is
an inclusive operation with none defaulting to be included unless specified, if
any -c exists).  Or any other flag/scheme, the important functionality being
only upgrading packages in specific channels while allowing dependencies be
pulled all channels.
Comment 1 Adrian Likins 2002-02-13 17:21:29 EST
I think we are going to need to always include the base channel,
but allow selected child channels to be included. It doesnt
really make since otherwise (use channel X at this point,
but channel B at that point, and both at this other point elsewhere...)
All the rules we tell child channel makers seem to blow up at
that point as well (basically, you can have deps on the base channel stuff)

The intent seems to be to allow all packages of a channel downloaded
at once, which is kind of a orthogonal problem and probabaly best
as a seperate RFE.

Note You need to log in before you can comment on or make changes to this bug.